Can't get meteor to start

#1

Hey all, I can’t seem to get meteor to start. I’ve tried a bunch of things but nothing has worked so far. I’m on windows 10, had to add git to my Path, did a few other things but nothing seems to work and I’ve got an error that I’m not finding anywhere else on the internet:

W20180531-19:53:45.448(-7)? (STDERR) D:\Users\FileThirteen\Documents\GitHub\simple-todos.meteor\local\build\programs\server\boot.js:475
W20180531-19:53:45.451(-7)? (STDERR) }).run();
W20180531-19:53:45.452(-7)? (STDERR) ^
W20180531-19:53:45.453(-7)? (STDERR)
W20180531-19:53:45.455(-7)? (STDERR) Error: Cannot find module ‘meteor/http’
W20180531-19:53:45.456(-7)? (STDERR) at Function.Module._resolveFilename (module.js:547:15)
W20180531-19:53:45.461(-7)? (STDERR) at Function.resolve (internal/module.js:18:19)
W20180531-19:53:45.462(-7)? (STDERR) at Object.require (D:\Users\FileThirteen\Documents\GitHub\simple-todos.meteor\local\build\programs\server\boot.js:288:32)
W20180531-19:53:45.464(-7)? (STDERR) at makeInstallerOptions.fallback (packages\modules-runtime.js:651:18)
W20180531-19:53:45.465(-7)? (STDERR) at require (packages\modules-runtime.js:244:16)
W20180531-19:53:45.466(-7)? (STDERR) at client.js (packages\dynamic-import.js:409:12)
W20180531-19:53:45.467(-7)? (STDERR) at fileEvaluate (packages\modules-runtime.js:343:9)
W20180531-19:53:45.467(-7)? (STDERR) at require (packages\modules-runtime.js:238:16)
W20180531-19:53:45.471(-7)? (STDERR) at server.js (packages\dynamic-import.js:33:16)
W20180531-19:53:45.471(-7)? (STDERR) at fileEvaluate (packages\modules-runtime.js:343:9)
=> Exited with code: 1

Any help is appreciated. Thanks.

#2

Have you try meteor add http?

#3

I have not tried it yet. I will try it right now and get back to you. Alright I tired that and it didn’t work. It returned “http: Make HTTP calls to remote servers”, but I then tried to run meteor again and got the same result.

#4

Does a brand new Meteor project run? (ie. a new project from meteor create)

#5

That’s what this is. It’s my first project. I’m trying to follow the tutorials and this is just a brand new project.

Edit:
So I think I figured out the problem. I was trying to install it a few times and each time it would hang up when taking the chocolately route, but I saw a windows installer for it and just used that, I think it installed a super old version or something and maybe only partially. After all that tinkering I decided to retry the chocolately route and it said it was uninstalling the partial install that was already there and then reinstalled without incident. I just made a new project and tried to start it.

It looks like I was wrong that did not solve it. Still getting the cannot find module ‘meteor/http’.

Curious could having a symbolic link for my Users folder from my C drive to my D drive be causing the issue?

#6

It could definitely be that.
Not sure if it was the same thing but I remember there being some reason Meteor didn’t want to work on projects not on C drive last time I tried.

#7

Also, since you’re just starting out with Meteor on Windows I’ll give you the advice I give everyone:

99% of Windows / speed issues with Meteor are caused by anti-virus slowing down file operations, as there are A LOT of files involved in node apps.

I always add exclusions to Windows Defender for:

  • node.exe
  • 7z.exe
  • meteor.bat
  • mongod.exe
  • and the meteor folder at C:\Users%USERNAME%\AppData\Local.meteor\

This speeds up installs, updates, and builds by about 500%

#8

Thanks. I wonder what the best way to work around the symlink thing is.