Can't get started (Windows 10 related?)


#1

I’m interested in beginning developing apps with Meteor, but on 2 separate Windows 10 computers I am having the same problem:

  1. I Installed meteor here: https://www.meteor.com/install

  2. From command prompt I did the following (per the first step of the Meteor - Angular 2 tutorial):

C:\al>meteor create socially
Created a new Meteor app in ‘socially’.

To run your new app:
cd socially
meteor

If you are new to Meteor, try some of the learning resources here:
https://www.meteor.com/learn

C:\al>cd socially

C:\al\socially>meteor
[[[[[ C:\al\socially ]]]]]

=> Started proxy.
=> Started MongoDB.
Errors prevented isopacket load:

While loading isopacket ddp:
module.js:338:15: Cannot find module './_baseClone’
at Function.Module._resolveFilename (module.js:338:15)
at Function.Module._load (module.js:280:25)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(C:\Users\ATN\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\isopackets\ddp\npm\node_modules\meteor\babel-compiler\node_modules\babel-plugin-transform-es2015-modules-commonjs\node_modules\babel-types\node_modules\lodash\clone.js:1:17)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Module.Mp.load
(C:\Users\ATN\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\reify\node\runtime.js:16:23)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(C:\Users\ATN\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\isopackets\ddp\npm\node_modules\meteor\babel-compiler\node_modules\babel-plugin-transform-es2015-modules-commonjs\node_modules\babel-types\lib\index.js:314:38)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Module.Mp.load
(C:\Users\ATN\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\reify\node\runtime.js:16:23)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(C:\Users\ATN\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\isopackets\ddp\npm\node_modules\meteor\babel-compiler\node_modules\babel-plugin-transform-es2015-modules-commonjs\node_modules\babel-template\lib\index.js:84:43)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Module.Mp.load
(C:\Users\ATN\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\reify\node\runtime.js:16:23)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(C:\Users\ATN\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\isopackets\ddp\npm\node_modules\meteor\babel-compiler\node_modules\babel-plugin-transform-es2015-modules-commonjs\lib\index.js:525:46)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Module.Mp.load
(C:\Users\ATN\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\reify\node\runtime.js:16:23)
at Function.Module.load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
.extend.Npm.require (C:\tools\isobuild\bundler.js:1570:22)
at Object.require (C:\tools\isobuild\bundler.js:1547:11)
at Package (packages/babel-compiler/babel-compiler.js:17:1)
at packages/babel-compiler/babel-compiler.js:356:1
at packages/babel-compiler/babel-compiler.js:356:1

=> Errors prevented startup:

While loading plugin compile-ecmascript from package ecmascript:
module.js:338:15: Cannot find module './_baseClone’
at Function.Module._resolveFilename (module.js:338:15)
at Function.Module._load (module.js:280:25)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(C:\Users\ATN\AppData\Local.meteor\packages\ecmascript\0.4.4\plugin.compile-ecmascript.os\npm\node_modules\meteor\babel-compiler\node_modules\babel-plugin-transform-es2015-modules-commonjs\node_modules\babel-types\node_modules\lodash\clone.js:1:17)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Module.Mp.load
(C:\Users\ATN\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\reify\node\runtime.js:16:23)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(C:\Users\ATN\AppData\Local.meteor\packages\ecmascript\0.4.4\plugin.compile-ecmascript.os\npm\node_modules\meteor\babel-compiler\node_modules\babel-plugin-transform-es2015-modules-commonjs\node_modules\babel-types\lib\index.js:314:38)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Module.Mp.load
(C:\Users\ATN\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\reify\node\runtime.js:16:23)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(C:\Users\ATN\AppData\Local.meteor\packages\ecmascript\0.4.4\plugin.compile-ecmascript.os\npm\node_modules\meteor\babel-compiler\node_modules\babel-plugin-transform-es2015-modules-commonjs\node_modules\babel-template\lib\index.js:84:43)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Module.Mp.load
(C:\Users\ATN\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\reify\node\runtime.js:16:23)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(C:\Users\ATN\AppData\Local.meteor\packages\ecmascript\0.4.4\plugin.compile-ecmascript.os\npm\node_modules\meteor\babel-compiler\node_modules\babel-plugin-transform-es2015-modules-commonjs\lib\index.js:525:46)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Module.Mp.load
(C:\Users\ATN\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\reify\node\runtime.js:16:23)
at Function.Module.load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
.extend.Npm.require (C:\tools\isobuild\bundler.js:1570:22)
at Object.require (C:\tools\isobuild\bundler.js:1547:11)
at Package (packages/babel-compiler/babel-compiler.js:17:1)
at packages/babel-compiler/babel-compiler.js:356:1
at packages/babel-compiler/babel-compiler.js:356:1

While loading plugin compileTemplatesBatch from package templating:
module.js:338:15: Cannot find module './_baseClone’
at Function.Module._resolveFilename (module.js:338:15)
at Function.Module._load (module.js:280:25)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(C:\Users\ATN\AppData\Local.meteor\packages\templating\1.1.10\plugin.compileTemplatesBatch.os\npm\node_modules\meteor\babel-compiler\node_modules\babel-plugin-transform-es2015-modules-commonjs\node_modules\babel-types\node_modules\lodash\clone.js:1:17)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Module.Mp.load
(C:\Users\ATN\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\reify\node\runtime.js:16:23)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(C:\Users\ATN\AppData\Local.meteor\packages\templating\1.1.10\plugin.compileTemplatesBatch.os\npm\node_modules\meteor\babel-compiler\node_modules\babel-plugin-transform-es2015-modules-commonjs\node_modules\babel-types\lib\index.js:314:38)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Module.Mp.load
(C:\Users\ATN\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\reify\node\runtime.js:16:23)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(C:\Users\ATN\AppData\Local.meteor\packages\templating\1.1.10\plugin.compileTemplatesBatch.os\npm\node_modules\meteor\babel-compiler\node_modules\babel-plugin-transform-es2015-modules-commonjs\node_modules\babel-template\lib\index.js:84:43)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Module.Mp.load
(C:\Users\ATN\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\reify\node\runtime.js:16:23)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(C:\Users\ATN\AppData\Local.meteor\packages\templating\1.1.10\plugin.compileTemplatesBatch.os\npm\node_modules\meteor\babel-compiler\node_modules\babel-plugin-transform-es2015-modules-commonjs\lib\index.js:525:46)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Module.Mp.load
(C:\Users\ATN\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\reify\node\runtime.js:16:23)
at Function.Module.load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
.extend.Npm.require (C:\tools\isobuild\bundler.js:1570:22)
at Object.require (C:\tools\isobuild\bundler.js:1547:11)
at Package (packages/babel-compiler/babel-compiler.js:17:1)
at packages/babel-compiler/babel-compiler.js:356:1
at packages/babel-compiler/babel-compiler.js:356:1

=> Your application has errors. Waiting for file change.


Any ideas?


#2

Also, I tried the same thing on my remote linux server with no issues. (So something to do with the windows installer???)


#3

I’ve got the same issue since yesterday, anyone knows whats the problem? Can’t use meteor :frowning:


#4

This is a known issue:

A patch is coming in release 1.3.3.1.


#5

We have to stop working until there is an update?

Can we downgrade?


#6

I tried doing meteor create --release 1.3.2.4 app name but it doesn’t work. It’s stuck forever on downloading meteor-tool.

Edit - After 20 mins(:joy:), it actually installed it and it works.


#7

Yep…same here.
No ideas yet.


#8

Luckily it sounds like Meteor 1.3.3.1 is coming out later today.


#9

Awesome; is there any guide to updating my installation of meteor with the latest in the github repo? I was hoping not to have to figure out how to build it from source (probably harder on Windows than on linux or iOS?)


#10

No need to worry about building it from source - you can now:

meteor update --release 1.3.3.1

#11

Hmm, a similar error (again related to the absurd file path length limit in windows?)

C:>meteor update --release 1.3.3.1

Errors prevented isopacket load:

While loading isopacket ddp:
module.js:338:15: Cannot find module './_baseClone’
at Function.Module._resolveFilename (module.js:338:15)
at Function.Module._load (module.js:280:25)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(C:\Users\ATN\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\isopackets\ddp\npm\node_modules\meteor\babel-compiler\node_modules\babel-plugin-transform-es2015-modules-commonjs\node_modules\babel-types\node_modules\lodash\clone.js:1:17)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Module.Mp.load
(C:\Users\ATN\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\reify\node\runtime.js:16:23)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(C:\Users\ATN\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\isopackets\ddp\npm\node_modules\meteor\babel-compiler\node_modules\babel-plugin-transform-es2015-modules-commonjs\node_modules\babel-types\lib\index.js:314:38)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Module.Mp.load
(C:\Users\ATN\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\reify\node\runtime.js:16:23)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(C:\Users\ATN\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\isopackets\ddp\npm\node_modules\meteor\babel-compiler\node_modules\babel-plugin-transform-es2015-modules-commonjs\node_modules\babel-template\lib\index.js:84:43)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Module.Mp.load
(C:\Users\ATN\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\reify\node\runtime.js:16:23)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(C:\Users\ATN\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\isopackets\ddp\npm\node_modules\meteor\babel-compiler\node_modules\babel-plugin-transform-es2015-modules-commonjs\lib\index.js:525:46)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Module.Mp.load
(C:\Users\ATN\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\reify\node\runtime.js:16:23)
at Function.Module.load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
.extend.Npm.require (C:\tools\isobuild\bundler.js:1570:22)
at Object.require (C:\tools\isobuild\bundler.js:1547:11)
at Package (packages/babel-compiler/babel-compiler.js:17:1)
at packages/babel-compiler/babel-compiler.js:356:1
at packages/babel-compiler/babel-compiler.js:356:1

C:\Users\ATN\AppData\Local.meteor\packages\meteor-tool\1.3.3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\meteor-promise\promise_server.js:165
throw error;
^
Error: isopacket load failed?
at loadIsopacketFromDisk (C:\tools\tool-env\isopackets.js:286:11)
at C:\tools\tool-env\isopackets.js:88:23
at Object.exports.noYieldsAllowed (C:\tools\utils\fiber-helpers.js:37:14)
at Object.load (C:\tools\tool-env\isopackets.js:80:23)
at new ServiceConnection (C:\tools\meteor-services\service-connection.js:29:28)
at Object.exports.openServiceConnection (C:\tools\meteor-services\auth-client.js:12:10)
at openPackageServerConnection (C:\tools\packaging\package-client.js:21:21)
at _updateServerPackageData (C:\tools\packaging\package-client.js:149:14)
at C:\tools\packaging\package-client.js:127:12
at C:\tools\utils\buildmessage.js:334:18
at [object Object].withValue (C:\tools\utils\fiber-helpers.js:89:14)
at C:\tools\utils\buildmessage.js:333:36
at [object Object].withValue (C:\tools\utils\fiber-helpers.js:89:14)
at Object.enterJob (C:\tools\utils\buildmessage.js:324:26)
at Object.exports.updateServerPackageData (C:\tools\packaging\package-client.js:126:23)
at C:\tools\packaging\catalog\catalog-remote.js:777:36
at C:\tools\utils\buildmessage.js:334:18
at [object Object].withValue (C:\tools\utils\fiber-helpers.js:89:14)
at C:\tools\utils\buildmessage.js:333:36
at [object Object].withValue (C:\tools\utils\fiber-helpers.js:89:14)
at Object.enterJob (C:\tools\utils\buildmessage.js:324:26)
at RemoteCatalog.refresh (C:\tools\packaging\catalog\catalog-remote.js:776:18)
at Object.catalog.refreshOrWarn (C:\tools\packaging\catalog\catalog.js:48:22)
at C:\tools\cli\main.js:935:19
at Console.withProgressDisplayVisible (C:\tools\console\console.js:631:14)
at C:\tools\cli\main.js:934:17