Can't get updates to Android Emulator (Hot Code Push)


#1

I’m doing mobile development on an Android Emulator with Genymotion. I can’t get any code changes to show up on the emulator. I always get this error, even on Startup:

Skipping downloading new version because the Cordova platform version or plugin versions have changed and are potentially incompatible

I know this a protection mechanism from bad updates, but It happens all the time. I can’t even make a small CSS or JS change. They all get blocked. I tried it on Android 4.4.4, 5.0 and 6.0.

Anyone know what’s causing this?


#2

@martijnwalraven, have you seen this before?

I couldn’t find any solution from my research. All changes get blacklisted from some reason.


#3

You have probably done this already… but I would try running a new build through google play… that would in theory have all the same versions of cordova libs and mobile-config access paths etc.

At that point… making a trivial js change (like a version string) should get hot pushed.

If you tried this isolated test, my next question would be which version of Meteor are you using?


#4

Thanks for the suggestion. This isn’t a production app and has never been published. I’m only working on it in development right now. I just simply start the device in Genymotion and run:

meteor run android-device

and it starts in the Genymotion emulator. I instantly see the error and the files aren’t updated.

I’m running the latest version. Meteor 1.4.1.2 I believe.


#5

I downloaded a totally new device from Genymotion and it’s still the same thing! When it ran it on the totally new device, it had old files that aren’t in my project anymore, or background colors that are different. It’s like it’s serving up a cached version of the Android build and won’t get the new one. I think removing the android platform from my project and re adding it would update the files, but then it still blocks new ones all over again. Very weird.


#6

I confirmed that this is a problem with crosswalk. After I removed it, I can do hot code push and nothing gets blocked.

I added crosswalk the recommended way of meteor add crosswalk. I think I’m going to try to add it in as a cordova plugin instead and see if that produces any different result.


#7

Confirmed this doesn’t work with adding crosswalk as a cordova plugin instead.


#8

Wow, I take back my last couple posts. It was working fine, but when I went to work on it today the exact same thing happened with no Crosswalk. This is just insane. I have no clue what I’m doing wrong and I can’t do dev work on Android. Everything is totally blocked.

@martijnwalraven Do you have any idea what’s causing this?