Cant install Meteor on Windows 10


#1

I upgraded to Windows 10 and am trying to install Meteor 1.2

I ran the windows installer and a have %LOCALAPPDATA%\.meteor on my path, still I cant launch meteor from the command line.

Infact my folder only has a packages folder and does not have any batch files etc.

What am I doing wrong?


#2

What does just entering meteor into the command line do?


#3

Gives a command not found error.


#4

Hello shaunakde,

check if meteor is added in your path variable

C:\Users\Dinesh\AppData\Local.meteor


#5

sorry forgot to mention : in your system path variable

I had similar problem, i checked that the meteor path was only added in user enviorment variable, I added it to the system and it worked.


#6

The path and everything are set. I think the installer has a few bugs in
windows. Filled a bug report.


#7

i just installed at windows 10. Installer add environment variable for user section… i add it for system path and works fine.

C:\Users\username\AppData\Local\.meteor\

#8

This has worked for me on Windows 10, after standard installer failed:

For your convenience the contents of the link:

On some network or machine setups Meteor’s installer for Windows may fail. In such cases, follow these simple steps to install Meteor manually:

Install 7-Zip or any other program that knows how to extract tar.gz files.
Download the installation archive from https://packages.meteor.com/bootstrap-link?arch=os.windows.x86_32.
In a command prompt, run echo %LocalAppData%.meteor – this is the directory in which Meteor should be installed.
Extract the installation archive into the directory above.
Add this directory to your PATH environment variable.
You should now be able to open a new command prompt and run meteor. Some versions of Windows may require restarting your machine first.


#9

First, what is the purpose of echo %LocalAppData%.meteor? It doesn’t create the .meteor folder and only echos the string passed to it to the console.

Am I missing something? The .tgz file contains a .tar file which is what needs to be extracted. 7Zip only puts that file in the .meteor folder.

Once I extract that into the %LocalAppData%.meteor folder, I can run meteor which returns message that you’re not in a meteor folder and the syntax examples i.e. meteor create .

meteor create myapp still does nothing but hang.

meteor update in a non-app folder does nothing but hang

Does this all just not work on a 64 bit machine? Is that my problem?


#10

I work on Win10 x64 for months without any issues (like the problem described here)
Remove older meteor and node installations or create a new user account and install using it.
Check the paths and ENV variables.
It’s just working for me …

One more, have the Cygwin installed as well. Could be some linux based commands are what you need.