Can't publish package for Windows architeture


#1

Hello, I can’t publish my package to windows architecture, I always get this error:

=> Errors while publishing build:

While uploading build:
error: Error: ETIMEDOUT

I’ve tried meteor publish-for-arch package@version and meteor publish --update.


#2

At the moment MDG does not provide a package build environment for Windows. However, if you do a normal meteor publish from a Windown machine, the package will be for Windows (the build machine is your own OS in this case). From a Windows machine, you can if you need to, publish for linux and Mac.

Most time you do not need to be concerned about the architecture for your package (it’s probably all Javascript) and just doing a vanilla publish is sufficient. To quote the docs (my emphasis, below):

Sometimes packages may contain binary code specific to an architecture (for example, they may use an npm package). In that case, running publish will only upload the build to the architecture that you were using to publish it. You can use publish-for-arch to upload a build to a different architecture from a different machine.


#3

Exactly I’ve never worried about that, meteor publish was enough. I’ll try another version of the package.

Thanks


#4

I’ve tried to publish a new version of the package from Linux as I always did before, the same error:

meteor publish
=> Errors while publishing:                   
                                              
While uploading build:
error: Error: ETIMEDOUT

#5

What release you are running? there was as short update to 1.3.4 upto 1.3.4.1 in case of http utils timeout.

Maybe you try a meteor update before publish


#6

I’ts not working even with 1.3.4.1 meteor version :confused:

Maybe meteor infrastructure have problems??


#7

Sorry, I am out - maybe you ask some MDG stuff


#8

@sashko any ideas about this??


#9

I suspect this is due to slow upload speed. I tested publishing after limiting my upload speed and it resulted in the same issue. They might have reduced the timeout. BTW I’m using a linux system.