Can't run app issue


#1

I hired a contractor, but he can’t get our app to run.

  blackship git:(develop) ✗ npm start

> blackship-design@ start /Users/vstlouis/code/white-rabbit-japan/blackship
> MONGO_URL=mongodb://localhost:27017/wreshared ROOT_URL=http://localhost:3010 meteor run --settings development.json --port 3010

[[[[[ ~/code/white-rabbit-japan/blackship ]]]]]

=> Started proxy.

Unable to resolve some modules:

 "node-quickbooks" in /Users/vstlouis/code/white-rabbit-japan/blackship/imports/api/whiterabbit-quickbooks/quickbooksUtils.js (os.osx.x86_64)
 "cookie-parser" in /Users/vstlouis/code/white-rabbit-japan/blackship/imports/api/quickbooksOAuth/serverRoutes.js (os.osx.x86_64)
 "express-session" in /Users/vstlouis/code/white-rabbit-japan/blackship/imports/api/quickbooksOAuth/serverRoutes.js (os.osx.x86_64)
 "paypal-rest-sdk" in /Users/vstlouis/code/white-rabbit-japan/blackship/imports/api/whiterabbit-payments/paypalExpressUtils.js (os.osx.x86_64)

If you notice problems related to these missing modules, consider running:

 meteor npm install --save node-quickbooks

if I pull the project, run npm install then npm start it works. But on his machine he gets this error, even after running npm install multiple times.

We are using same version of npm, node and meteor. Not sure what to try next.


#2

Same operating system too?


#3

We are both in OS X. I didn’t check which version. If it were different what should we consider?


#4

Well if you’re both on OS X it should be fine. I’ve had issues between Windows and OS X versions of apps (not necessarily Meteor) but I don’t really understand why you’re both having issues on OS X. Sorry :frowning:


#5

That’s really odd. On his machine, after doing npm install, if you look in node_modules, are those packages (node-quickbooks etc) truly not there? Is there an npm debug log hanging around that might have some errors in it? Permissions issue?


#6

Not sure if it’s exactly the same issue, but I ran into something similar on different Ubuntu machines and ended up using https://guide.meteor.com/using-npm-packages.html#npm-shrinkwrap


#7

I had a similar issue on a project but on different OSs (OSX vs Ubuntu). The thing that solved it in the end was reinstalling meteor and the project from scratch. I know, not ideal, but hey.


#8

rm -rf ~/.meteor BTW. Unless there’s a more elegant way. :wink:


#9

That’s the only way I know :grin:


#10

Thanks guys. I’ll suggest he start by simply deleting node_modules. Also will get a copy of the log.