Can't run app on Android 6.0.1


#1

I have tried everything I can think of to get a Meteor app running on an Android phone and everything I try leaves me in the same place: “There was a problem parsing the package”.

The phone I’m trying to test on is running Android OS 6.0.1. The app I’m currently trying to test with is the todos app from Meteor’s tutorial (https://github.com/meteor/todos).

I begin by building with “meteor build ~/out --server http://myserver”. Then I start the app at http://myserver, download the .apk file from ~/out and try to install it.

The phone is configured to allow installing apps from unknown sources. I’ve tried zipaligning and signing the apk file, and that made no difference.

I’m out of things to try. Can anybody offer some guidance? Is it a version problem? Is 6.0.1 too new? I tried both the ARM and x86 versions of the apk with the same result. Nothing works and the error is just not enough to go on. Any help at all would be greatly appreciated. Thank you!


#2

Manage to solve it? i’m having the same issue. It had previously worked on older versions of Android