Can't update to 1.3.5.1 - errors


#1

Hi guys!

So I am on a Macbook developing my Meteor application since forever. Now I am running into problems updating to 1.3.5.1 (I think that’s the newest version atm right?).
This project is currently running Meteor 1.3.4.1!
On my system Node v4.1.2 and the newest NPM are installed. Maybe I am wrong but Meteor still ships with “it’s own” v0.10.46 Version of Node right?
Anyways … here is the errors I get:

=> Errors while initializing project:

While loading package fourseven:scss@3.4.3:
error: Command failed:
module.js:340
throw err;
^
Error: Cannot find module '…/'
at Function.Module._resolveFilename (module.js:338:15)
at Function.Module._load (module.js:280:25)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.
(/Users/Patrick/.meteor/packages/fourseven_scss/.3.4.3.10hu8xj++os.osx.x86_64+web.browser+web.cordova/plugin.compileScssBatch.os.osx.x86_64/npm/node_modules/meteor/compileScssBatch/node_modules/.temp-1appitv/node_modules/node-sass/node_modules/cross-spawn/node_modules/spawn-sync/node_modules/try-thread-sleep/node_modules/thread-sleep/node_modules/.bin/node-pre-gyp:15:20)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Function.Module.runMain (module.js:497:10)

npm ERR! Darwin 15.5.0
npm ERR! argv “node”
"/Users/Patrick/.meteor/packages/meteor-tool/.1.3.5_1.8qvgc6++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/dev_bundle/bin/npm"
“rebuild” “–no-bin-links” "–update-binary"
npm ERR! node v0.10.46
npm ERR! npm v3.10.5
npm ERR! code ELIFECYCLE
npm ERR! thread-sleep@1.0.4 install: node-pre-gyp install --fallback-to-build
npm ERR! Exit status 8
npm ERR!
npm ERR! Failed at the thread-sleep@1.0.4 install script ‘node-pre-gyp install
–fallback-to-build’.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the thread-sleep
package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-pre-gyp install --fallback-to-build
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs thread-sleep
npm ERR! Or if that isn’t available, you can get their info via:
npm ERR! npm owner ls thread-sleep
npm ERR! There is likely additional logging output above.

Can someone help? Thanks a bunch in advance!

best, P


#2

funnily enough i resolved a similar error with fourseven:scss just 5 minutes ago ^^
while it worked fine on win8, on debian it crashed on update, run and list.

running meteor update as root, then sudo meteor run -p 80 as normal user solved it for me.


#3

Just tried sudo meteor update - didn’t change anything! :pensive:


#4

sudo meteor update didn’t work for me either. try:

su
[root password]
meteor update
exit
sudo meteor run -p 80
[user password]


#5

Tried that as well - first it downloads Meteor all over again because of different user (root), and then at some point the same error occurs.


Meteor upgrade conflict with fourseven: scss@ 3.3.3_3
#6

Fixed it!

What I did:
run meteor update fourseven:scss first and normal meteor update afterwards.


#7

@klabauter It worked for me as well. Thanks! :slight_smile:


#8

I was running Meteor 1.3.4-rc.2. Still had the error.
Had to downgrade to Meteor 1.3.4.1 then it worked :slight_smile:


#9

This just happened to me on Windows :frowning:

Running with powershell as admin. Any tips?


#10

whats your meteor version?


#11

Nevermind I got around it by removing fourseven:scss, updating and then re-adding that package. Weird.


#12

This worked for me as well.


#13

My fourseven is giving an EACESS error despite being root user, sudo, and SIP disabled.

I tried updating fourseven and got the error.

Tried removing, updating, adding technique and also not working (can’t re-add package, same error).

:\