Cloudflare breaks app with DISABLE_WEBSOCKETS=1


#1

Hello I’m following @arunoda instructions here: https://meteorhacks.com/cloudflare-meets-meteor.html
I’m wondering if this is deprecated information. Cloudflare, free, seems to work fine with Websockets. Ironically it breaks when I turn it OFF (DISABLE_WEBSOCKETS=1).

I have disabled the websockets, as stated in “Option 1” in the tutorial, using MUP to deploy on Digital Ocean. XHR requests are failing with “Canceled”.

Another blog has a hint about Pseudo IPv4 setting needs to be set to “Overwrite Headers”. But it also did nothing: http://help.modulus.io/customer/portal/articles/1929796-cloudflare-configuration-with-meteor-xhr-polling

What are the up-to-date instructions on running Meteor with CloudFlare?

Versions:
Meteor 1.1.0.2
meteor-platform 1.2.2 Include a standard set of Meteor packag…
meteorhacks:cluster 1.6.3 Clustering solution for Meteor with loa…
meteorhacks:kadira 2.20.1 Performance Monitoring for Meteor


#2

Solved.

Cloudflare’s minification settings conflicts with DISABLE_WEBSOCKETS=1. Just turn off at Cloudflare>Speed>Auto Minify. You wouldn’t need it with Meteor anyway.