CollectionFS, Amazon S3 file uploading broken on Galaxy


#1

Hi,

everything works on localhost, but not when deploying to Galaxy.
I select a file and Chrome says “PUT https://mysite... net::ERR_SPDY_PROTOCOL_ERROR”

then “Error: “Queue” network [undefined], Error: network [undefined]” for serveral times.

I’m using CollectionFS with autoform-file and GridFS as temporary storage. Files should be uploaded to Amazon S3 and uploading works sometimes even from Galaxy. (also installed cfs:filesystem, but no help)

FS.debug is set to true, but no much help. No errors in serverside, just clientside errors.

My MongoDB is in Amazon AWS and bucket for files S3. Galaxy app region is us-west-1 and S3 and mongo are located in eu-west-1.

Help is needed. I cannot develop with Meteor if thingks working so differently in Galaxy and another servers.

Anything to try?


#2

It could be due to browser caching: http://techdows.com/2015/08/fix-chromes-err_spdy_protocol_error.html


#3

Thanks rob!

Same issue exists in firefox too with the error:

Error: “Queue” failed [502] 502 Bad Gateway: Registered endpoints failed to handle the request. [undefined], r.makeErrorType/n@https://mysite


#4

Hi, did you find any solution for your issue? I have the same error 502 Bad Gateway: Registered endpoints failed to handle the request when trying to use collection fs with meteor-uploads on Galaxy. Thanks


#5

You’re using the wrong region !! Check your s3 region and set it in the s3 package config


#6

I switched to Slingshot https://github.com/CulturalMe/meteor-slingshot

Works like a charm!


#7

I got this from Google while searching for ways to resolve my problem. It would be helpful to you too.

https://usefulpcguide.com/18302/fix-err_spdy_protocol_error-google-chrome/


#8

Yes i tried that while ago. Didn’t help.


#9

i Found a Website from which i get rid out of this error issue, you can also check this once from here: http://www.techinpost.com/fixed-error-hal_initialization_failed-code-problem


#10

You can Run ipconfig/release command it will solve your issue easily, If you are not able to solve then follow this issue https://www.howtoseeks.com/err_spdy_protocol_error/


#11

How to run ipconfig (which is a Windows command btw) on Meteor Galaxy?


#12

I’m pretty sure, this might solve your issue if still you’re facing it:

  1. Visit “chrome://net-internals/#sockets page” from the browser address bar

  2. Tap on ‘Flush Socket Pools’, and check the page or site you’re having the issue to see its loading appropriately.

  3. Open the cmd as Admin and Flush the DNS by running the underneath command.

ipconfig/flushdns

  1. From that point onward, run the underneath statements which renews the IP address.

ipconfig/discharge

ipconfig/recharge

  1. In case you’re utilizing Avast, attempt to include the sites, to which you’re getting the error to the Web Shield exclusions, here is the manner by which you can do that.

  2. Open Avast GUI > Settings > Active Protection, tap on Customize for ‘Web Shield’ and include site URL one by one under ‘URLs to exclude:’ area.

Make sure that you’ve restarted the browser and cleared the Chrome cache before endeavoring above strategies to settle err spdy protocol error.

Refer these guide if you need more information:

https://productforums.google.com/forum/#!topic/chrome/sfAqeo4hDy8

https://www.techwhoop.com/fix-err_spdy_protocol_error/


#13

I ran into same issue on Galaxy when uploading files into DB. No error whatsoever in localhost. I didn’t use CollectionFS.


#14

I am having the problem with my upload functionality when i enable Secure Connection i.e HTTPS, the error i am getting is Failed to load resource: net::ERR_SPDY_PROTOCOL_ERROR Disabling the HTTPS and running the app via HTTP protocol it works perfectly fine. Why my upload features is failing for https protocol only ?

I have tried to flush sockets and dns on chrome but nothing worked.

Furthermore I used https://spdycheck.org/ to check SPDY enabled on galaxy server, and received the following messages:

SPDY Protocol Not Enabled!
This SSL/TLS server is using the NPN Entension to tell browsers it supports alternative protocols, but SPDY is not a protocol it supports. The server is not making SPDY an option. Since all the pieces are in place, hopefully it will be easy to enable SPDY support with this server.


#15

There are many ways to fix it.
But i am suggesting you best and easy way to use Chrome Cleanup Tool.
These type tools will clear your cookies and catch . It will automatically fix if due to cookies error.
You can try other ways to fix these type errors


#17

just delete all the cache and cookies. I think it will work for you.