Configuring Server Error: "The Connection to the Server was unsuccessful (http://localhost:NaN)" message when testing on android


#1

It seems like I’m entirely failing to configure where the server is somewhere. I can SEE this in the config.xml file located in the cordova-build folder: .

But this is a generated filed that reverts if I attempt to edit it.

I’ve tried changing my ROOT_URL environmental variable. Is that the right direction?


#2

Hi, I have same problem. Can you help me?


#4

Having the same problem. Have you found any solution?


#5

yes, you need use this command line:

meteor build /path_to_build_destiny --mobile-settings settings-production.json --server http://app.domain.com

#6

@raragao thanks for the reply, however in my case the problem was in a .meteor/.id file. Removed the file so meteor generated a new one with next run to solve it.

see this issue for more details.