Connecting MongoDB Compass to Galaxy Hosted Mongo Db

Using:
mongodb://user:password@SG-galaxycluster-38726.servers.mongodirector.com:27017,SG-galaxycluster-38727.servers.mongodirector.com:27017/test-meteorapp-com?replicaSet=RS-galaxycluster-0&ssl=true

Does not work with MongoDB Compass as the connection string.
Please advise

Hi,
I was looking at something similar and focused on meteor mongo instead, at least for a start.
It seems this is supposed to work:
meteor mongo --url test-meteorapp-com
(if test-meteorapp-com is the name of your app)
But in my case right now this ends up in an error:

Talking to Galaxy servers at https://eu-west-1.galaxy-deploy.meteor.com
Couldn't open a mongo connection: Server error (please try again later)
Response missing expected keys.

(this looks promissing, though, I’ll try again later :wink:)

I contacted Galaxy support and got an answer!

They advised me to use NoSqlBooster (http://nosqlbooster.com/), a tool I didn’t know before.
By simply using the mongo URL found in settings.json, I was able to connect to my Galaxy Mongo instance, and voila!
See here

1 Like