Connecting to meteor.com with MongoVue


#1

Hey, I also posted this question to stackoverflow but didn’t get an answer.

I am having problems connecting via MongoVUE to the deployed version of my app at

app at app.meteor.com

I can connect to the db just fine using the console. The console also tells me the server db:

production-db-a2.meteor.io:27017/app_meteor_com

The error I get from mongoVue is the following:

Unable to connect to a member of the replica set matching the read preference

For username / password I used my meteor developer info

Here is a screenshot of my mongoVue input:

Help is very much appreciated
Hoping someone on here uses mongoVue to connect to the db

Thanks!


#2

Those credentials are only valid for a short time (used to be 1 minute).

Is it possible that it simply expired by the time you filled out all of the details?


#3

Hey, thanks for the reply

Ya I tried this several times, also the error does not seem to be pointing to authentication.
Are you running mongoVUE?


#4

No, but you seem to be correct about it not being directly related to the time limit.

From looking at the instructions on the MongoVUE website, it seems that it has a special “replica set” mode.

My guess is that since you specified the server RUI with the port, it automatically switched to this mode.


#5

Ok I was able to fix it…Was a credential issue after all.

Thanks for your help!


#6

Would you mind explaining what it was that fixed this issue for you? I’m running into this same problem, and can’t figure out what it is.


#7

Hey sorry for replying so late.

I actually did it with robomongo but just tried it in mongoVue and it works too…

Here are the steps:

  1. Go into your CMD , navigate to your app and type: meteor mongo yourappname.meteor.com -U

  2. You might be asked for credentials, these will be your meteor developer account credentials

  3. You are now given a string starting with client-username:password@server:port/my_app_name

  4. In your mongoVue you use the “client-username” part as Username, the “password” part as password, the “server” as server and the “port” as port. Lastly use you “my_app_name” as Databases

  5. You should now be good to go. There might be a time limit, not sure how long, I always did it under 1 minute.

Cheers
Shibbn


#8

No worries. Fortunately I was able to figure it out myself not much later, but forgot about posting here. Your instructions are spot on.

“meteor mongo --url yourappname.meteor.com” returns that same string with the necessary username and password.

Regardless, thanks for taking the time to respond.