Copied project, now stuck forever at Downloading meteor-tool


#1

I have a project at production, which I’ve copied locally and tried executing. No matter what command I issue locally at CLI (reset, update, run) the first thing Meteor tries to do is to “Download meteor-tool@1.3.3.1” (before I updated this, it was @1.1.9 or something). And then it’s just stuck there like forever. At first it was [2%==> ] downloading or something. now the progress bar has vanished and there’s just the spinner. I tried to see if this was a local issue by copying the project at various server instances but to no avail. They’re all stuck at the same stage, in the same way. Strangely though, if i “meteor create” a new project in a different folder, everything goes smoothly, the project is created in 10 seconds at most.

I also saw that the forums are also full of topics on this issue and it’s been going on since November. I swear, some people have said that the best way is to “leave your machine be and in the morning, the download will have finished”. Guys, are we back to 1998? It just doesn’t make any sense for the download of “meteor-tool” package to take longer than the download and installation of Meteor itself. This is a huge inconvenience and I’m sure it’s gotta be related to some kind of bug. Is there any work in progress on this? Or is there something I should do to


#2

okay i found myself a solution following this thread here (which I’ve seem to have missed) :slight_smile:
issue 6960 at meteor github.

in short, what I did was:

  1. “host d3fm2vapipm3k9.cloudfront.net” and get the IP,
  2. “sudo vi /etc/hosts” && add the IP i got from the step above into the table as “warehouse.meteor.com”, save file

temporary workaround, remember to restore the hosts file once youre done.


#3

Does anyone have a better resolution? This can’t be a permanent solution.


#4

This is a better solution for developers to try than changing symlinks or rm -rf and retry, which are time consuming.

I agree that ultimately whatever DNS issue they are responsible for maintaining needs to be fixed.