Cordova build fail to add plugins


#1

I run meteor 1.2.0.2. My project was just ok but I get this message when trying to rebuild for Android.
Any help would be great.
Thank you.
Vigile
++++++++++++++
=> Errors executing Cordova commands:

While adding plugin cordova-plugin-splashscreen@2.1.0 to Cordova project:
Cordova error: Failed to fetch plugin cordova-plugin-splashscreen@2.1.0 via registry.
Probably this is either a connection problem, or plugin spec is incorrect.
Check your connection and plugin name/version/URL.
undefined
(If the error message contains suggestions for a fix, note that this may not apply to the Meteor integration. You can try running again with the --verbose option to help
diagnose the issue.)


#2

Does specifying --verbose give more output?


#3

Thank you. I had the answer and I forgot to let you know. Sorry. Because of the upgrade of meteor in 1.2, you need to use sudo to run and build… if you don’t, cordova libs are not fetched properly. That’s it.
Bye.
Vigile


#4

Thanks for letting me know. It would be interested to know why that is the case, because I haven’t encountered it. Are you running on Mac or Linux? Where are you trying to build your project?


#5

Hi Martijn,
I run on OS X El Capitan 10.11.1 (15B42). I build my project in my classic ~/dev directory.
It’s fixed now. As you told me it never happened to you I decided to rm and re-install meteor and everything… and now it’s ok. Thank you for your “advice”. I think I used a sudo trying to install something in the past and then I needed it again to overwrite some file but I thought it was because of the meteor upgrade… :-S
Thanks
Vigile