Debugger not hitting breakpoints with 1.6.0.1 or 1.6.1


#1

I have tried using both 1.6 and 1.6.1 for the below

I recently moved to a new windows laptop, installed meteor (x64 arch)
using Chrome Version 66.0.3359.139 (Official Build) (64-bit). Previously was using 65.0.3325 Chrome. (It was also working fine on my old machine.)

i’m able to go to chrome://inspect, open up the Node Inspector. All the server side files are there. Can click to set breakpoints. But they never get hit.

client side breakpoints get hit just fine.

am at a complete loss for how to fix this. is freezing development. any ideas?

i have also tried VSCode to no avail.


#2

I am running into the same problem - did you ever find a solution?


#3

Started using vscode.
Run it in the terminal after setting it up… using
Meteor run --inspect --settings …/path/to file
Don’t run it with the green arrow.
Make sure auto attach is on, bottom left corner.
Might have to click cancel on some timeouts, and run it 2-3 times before all pieces sync up.

Seems like a WIP, but reliable once you get it going.


#4

WebStorm seems to work properly as well - must be specific to chrome. Hopefully they fix it in the future…


#5

Did you follow the cookbook? It worked for me without any problems.


#6

The link you provided is about how to use vs-code to debug meteor. This thread is about using the native chrome debugger (chrome://inspect) to debug meteor server applications.


#7

I’m still having this problem, for anyone still struggling to debug server side, the only way it works for me it to set the breakpoints with the debugger; keyword in code


#8

Same problem. I tried different setups with Chrome and VSCode, but in both my breakpoints get completely ignored. debugger; helped to stop chrome, but is not flexible enough for a real debug.

EDIT: Turns out debugger; will stop correctly, but afterwards I can’t step through the code line by line. Hitting step over next function call has the same effect as resume execution… So debugging is completely broken for me


#9

Same here; running Meteor 1.8 on Windows. Debugging has been broken for some time now, for sure when I was still on Meteor 1.7.0.1-5.

It did work before; no idea what’s changed. Is there a known issue on github?


#10

same here, debug is not working any more