Debugging just stopped working in VSCode

Meteor 2.10
January VSCode (rolled back from Feb)
Latest Chrome.

my launch config -

“configurations”: [
“type”: “chrome”,
“request”: “launch”,
“name”: “Meteor: Chrome”,
“url”: “http://localhost:3000”,
“webRoot”: “${workspaceFolder}”,
“outputCapture”: “std”
“type”: “node”,
“request”: “launch”,
“name”: “Meteor: Node”,
“runtimeExecutable”: “npm”,
“runtimeArgs”: [“run”, “debug”],
“outputCapture”: “std”,
“port”: 9229,
“timeout”: 30000

Basically this has been working forever and now it failed. Throughts on debugging this?

I am seeing this issue in the chrome debugger console in VSCode -

Could not read source map for http://localhost:3000/packages/modules.js?hash=929da37fca4c3fe9710f2b6fdfa7aed630c31e3f: Unexpected token < in JSON at position 0

but I am sure this is not new, and I have turned off the source map function in the chrome debug session, and this does not change the behaviour.

Basically the chrome instance comes up but the app won’t load. I am assuming it can’t connect to the debug port. Other local browsers can connect to the app without issue (no debug of course).

All the app resources are loading successfully in the debug instance of chrome…

connecting to the localhost debug port with chrome shut down on port 9229 is successful

updating the npms did not change the behaviour(remove - reinstall).

Another project has the same issues (much older meteor etc) but no < position 0 error. Which I suspected was spurious.

So the problem thickens. I just setup launch debugging in FireFox and it works perfectly. I will roll back to an older chrome version and try that.

Went back to chrome 107.x and chrome is working again. Really strange.

Spoke too soon on the first launch of chrome it works, on the next launch it fails.

Updating the vscode debugger to the latest nightly seems to have fixed the problem.