Dependencies conflicts


#1

Hello,
After updating Meteor to 1.6.1, I’ve got the following error :

=> Started proxy.
=> Errors prevented startup:

   While selecting package versions:
   error: Conflict: Constraint coffeescript@1.2.3 is not satisfied by coffeescript 1.0.17.
   Constraints on package "coffeescript":
   * coffeescript@1.0.4 <- manuel:reactivearray 1.0.6 <- mozfet:autoform-materialize 3.5.2
   * coffeescript@1.2.3 <- meteorstuff:materialize-modal 1.1.3
   * coffeescript@1.0.4 <- softwarerero:accounts-t9n 1.3.8 <- meteorstuff:materialize-modal 1.1.3

=> Your application has errors. Waiting for file change.

Does someone know how to resolve this kind of issue ?
I’ve try to force coffeescript to 1.2.3 by adding coffeescript@1.2.3 in package, but I still have conflit.


#2

You could try meteor add coffeescript@1.2.3 --allow-incompatible-update, but I suspect the issue is due to conflicts between the old v1 coffescript and the new v2 in Meteor 1.6.1:

This approach has been working well for the coffeescript-compiler package, for example. Speaking of CoffeeScript, while Meteor 1.6.1 was under development, a new major version of the coffeescript and coffeescript-compiler packages were released (most recently 2.0.3_4), which is worth mentioning for the same reason as the babel-compiler@7.0.0 upgrade: packages like practicalmeteor:mocha that depended on a 1.x version of coffeescript may need to be updated or replaced.

From:


#3

Your are right, I’ve got the following error :

=> Errors while adding packages:

While selecting package versions:
error: Conflict: Constraint babel-compiler@6.13.0 is not satisfied by babel-compiler 7.0.0.
Constraints on package "babel-compiler":
* babel-compiler@~7.0.0 <- top level
* babel-compiler@7.0.0 <- ecmascript 0.10.0
* babel-compiler@7.0.0 <- minifier-js 2.3.1 <- standard-minifier-js 2.3.1
* babel-compiler@7.0.0 <- standard-minifier-js 2.3.1
* babel-compiler@6.13.0 <- coffeescript 1.11.1_3

So I need to wait for third party package to be compatible with Meteor 1.6.1.
Imo, that’s not really what I could call a backward compatible update :confused:
Thanks for your reply


#4

Have you tried the latest coffeescript with that command?

Backwards compatibility has always been a huge concern in MDG, but can only really be tested with core functionality and core packages. These issues are with third-party packages.

You should maybe post an issue in the respective package GitHub repos. However, if the packages aren’t being maintained, then you can always git clone the packages and make the required dependency changes yourself. That’s really not difficult in Meteor.