Deploy to crashing

My hosted app was working two days ago. But today I found it was not responsive. I redeployed to try to kick it, but no success. I found that the app is crashing with server log showing ‘MongoError: Authentication failed’, see ‘meteor logs’ below. Any ideas? Is the meteor developer hosting system down? Thanks in advance for any help!


[Fri Dec 18 2015 01:31:12 GMT+0000 (UTC)] INFO STATUS waiting -> starting
[Fri Dec 18 2015 01:31:12 GMT+0000 (UTC)] INFO STATUS starting -> running
[Fri Dec 18 2015 01:31:13 GMT+0000 (UTC)] WARNING ^
[Fri Dec 18 2015 01:31:13 GMT+0000 (UTC)] WARNING /meteor/dev_bundles/0.5.16/lib/node_modules/fibers/future.js:278
[Fri Dec 18 2015 01:31:13 GMT+0000 (UTC)] WARNING MongoError: Authentication failed.
at Object.Future.wait (/meteor/dev_bundles/0.5.16/lib/node_modules/fibers/future.js:398:15)
at new MongoConnection (packages/mongo/mongo_driver.js:213:1)
at new MongoInternals.RemoteCollectionDriver (packages/mongo/remote_collection_driver.js:4:1)
at Object. (packages/mongo/remote_collection_driver.js:38:1)
at Object.defaultRemoteCollectionDriver (packages/underscore/packages/underscore.js:779:1)
at new Mongo.Collection (packages/mongo/collection.js:102:1)
at common.js:3:1
at common.js:8:1
at /meteor/containers/bf5fc590-58f2-047d-2fca-a5e2990e82e3/bundle/programs/server/boot.js:242:10
at Array.forEach (native)

at Object.toError (/meteor/containers/bf5fc590-58f2-047d-2fca-a5e2990e82e3/bundle/programs/server/npm/npm-mongo/node_modules/mongodb/lib/mongodb/utils.js:114:11)
at /meteor/containers/bf5fc590-58f2-047d-2fca-a5e2990e82e3/bundle/programs/server/npm/npm-mongo/node_modules/mongodb/lib/mongodb/db.js:1196:31
at /meteor/containers/bf5fc590-58f2-047d-2fca-a5e2990e82e3/bundle/programs/server/npm/npm-mongo/node_modules/mongodb/lib/mongodb/db.js:1905:9
at Server.Base._callHandler (/meteor/containers/bf5fc590-58f2-047d-2fca-a5e2990e82e3/bundle/programs/server/npm/npm-mongo/node_modules/mongodb/lib/mongodb/connection/base.js:453:41)
at /meteor/containers/bf5fc590-58f2-047d-2fca-a5e2990e82e3/bundle/programs/server/npm/npm-mongo/node_modules/mongodb/lib/mongodb/connection/server.js:488:18
at [object Object].MongoReply.parseBody (/meteor/containers/bf5fc590-58f2-047d-2fca-a5e2990e82e3/bundle/programs/server/npm/npm-mongo/node_modules/mongodb/lib/mongodb/responses/mongo_reply.js:68:5)
at [object Object]. (/meteor/containers/bf5fc590-58f2-047d-2fca-a5e2990e82e3/bundle/programs/server/npm/npm-mongo/node_modules/mongodb/lib/mongodb/connection/server.js:446:20)
at [object Object].emit (events.js:95:17)
at [object Object]. (/meteor/containers/bf5fc590-58f2-047d-2fca-a5e2990e82e3/bundle/programs/server/npm/npm-mongo/node_modules/mongodb/lib/mongodb/connection/connection_pool.js:207:13)
at [object Object].emit (events.js:98:17)

Have you tried re logging into Meteor? An easy way to do that would be just reinstall Meteor and when it gives you the option to login, login.

Yes tried ‘meteor login’ in again. I think I am obviously logged in because it allows me to ‘meteor deploy’, even though the resulting build crashes. And it allows ‘meteor logs’ command.

To be clear, the app works locally no problem.

It looks to be some issue between the connection between mongodb and the app itself. I haven’t seen it before sorry. I’m sure someone more knowledgeable then me will be able to work it out.

@logician, there were some changes made today on the free hosting. It is possible your app was affected. If so, there is a good chance it might be working again now. If not, and if you don’t have data you care about, you can try using meteor deploy --delete and redeploying. You can also check to see if we are reporting any problems at

@rdickert, Thanks for the reply! I checked the status and see that the dev hosting was experiencing issues this week. The current status says everything is up now, but my app is still down in the same way.

I tried deploying under a different name, and that works. So it seems that the issue is with the connection to my existing database. I would simply abandon the app and restart as you suggest. However the database has some data that I collected earlier in the week that I need.

I’m discussing this offline with @logician. If we find anything that is of value to everyone, I’ll post back.

All fixed. No data lost. Thanks Robert and MDG for the quick response! -Juan