Deploy to Zeit | meteor-now deployment basics


#1

Hey guys,

I decided to deploy my project to Zeit using the meteor-now package.
However, when I check the deployment (using the .sh URL or the alias) I don’t get my website, but rather a directory list. Apparently the problem is that I don’t have an “index file” for the “/” route… but I tried putting my project’s index.html file from the client folder to the root, and it didn’t work, either.

I tried two different commands: meteor-now and meteor-now -e ROOT_URL=http://myurl.com
My domain is correctly pointed to Zeit, so this is probably not the cause.

Any ideas what I could do?


#2

meteor-now does not work with zeit now 2.0
you should use version 1


#3

Thanks! Would never have guessed that. Do you know whether it is possible to downgrade Zeit or still download 1.0? (couldn’t find it)


#4

There’s a github issue regarding this: https://github.com/jkrup/meteor-now/issues/133

This is the second time in the past few months that now has made a change that made meteor-now incompatible. The first time was when they set a limit on built image sizes of 100mib. The workaround to this was to force now cloud v1: https://github.com/jkrup/meteor-now/issues/120

Regarding the newest change: On the now spectrum chat, a member of the now team said that the workaround mentioned above should let you continue using now v1, so I’m not sure why it’s not working: https://spectrum.chat/thread/8f78606f-17bd-41f3-8251-d5c05482d878?m=MTU0MjA1NjE2OTQyOQ==

Regardless of what happens, the creator of meteor-now has stated in that first (current) issue that he plans to keep the project going, possibly on a different platform. Pretty cool!


#5

I love meteor-now. you can specify now v1 in the now.json https://zeit.co/docs/v2/deployments/configuration#version


#6

Same! Meteor-now is awesome. Have you had success with using now.json though? In the past I found that now.json (or putting now settings in your package.json) did not work when deploying with meteor-now, hence why cloud v1 was put directly into meteor-now: https://github.com/jkrup/meteor-now/blob/0805a196ac41f63b96ff6e733027f3703bd565a1/src/api/docker.js#L86

Here’s the issue I made for that one: https://github.com/jkrup/meteor-now/issues/121

It seems like the link you provided may provide a fix for the time being though - maybe both "features": { "cloud" : v1" } and "version": 1 are necessary?


#7

One last thing - I just did a test deploy and everything worked fine, even without "version": 1, so I’m not sure what’s causing OP’s issue.

@patrickcneuhaus - what version of meteor-now are you using?


#8

It might work for you because you were already v1 user, so as long you don’t migrate your account to version 2 all your projects will be kept using v1 even you don’t specify them with version: 1.
So its important to both declare version: 1 and the v1 of docker.


#9

@qualitymanifest Thanks for the reply! I am using the latest version from meteor-now with NPM (0.7.0).


#10

I tried adding the now.json file with

{
    "features": {
       "cloud": "v1"
    }
}

but had no success. It still gives me a directory list instead of my app.

My file structure is:

  • .meteor
  • client
    - index.js (that imports the index.js files from imports/startup and the index.html file on the root)
  • imports
  • lib
  • node_modules
  • public
  • server
  • tests
    .gitignore
    now.json
    package-lock.json
    package.json
    index.html

I read through the discussions you guys mentioned, but unfortunately it is all looking very complicated to configure (and giving bugs where it shouldn’t). Any recommendations on a different solution to host simple Meteor apps for a very low entry price (let’s say lower than USD 10/month)?


#11

“Any recommendations on a different solution to host simple Meteor apps for a very low entry price (let’s say lower than USD 10/month)?”

You can host your app on NodeChef for $9


#12

I have one more idea, I just found a setting that might work:

Log on at zeit.co/now#

Go to your account page https://zeit.co/account

Scroll down to Platform Version and select v1 (assuming it isn’t selected already?) and click save

Then try deploying again. Please let me know if this works


#13

@qualitymanifest thanks changing this setting worked for me. Will be keeping an eye on this thread.


#14

Google compute engine 4.8$ month, depends your app, but google app engine recommended