Deployment failure Mupx meteor

I’am stuck in the deployment of my Meteor App on AWS.

Everything seems good to me.
Meteor Version :

Node version: v7.4.0
Npm version: 2.15.11

Docker running fine on server i checked it.
It there something related to meteor 1.4.x or mupx. ?
Can anyone please help me out on this ?


pm@2, which has some small
npm WARN deprecated backwards-incompatible changes made to npm run-script and
npm WARN deprecated semver behavior.
npm ERR! install Couldn't read dependencies
npm ERR! Failed to parse json
npm ERR! Unexpected end of input
npm ERR! File: /bundle/bundle/programs/server/package.json
npm ERR! Failed to parse package.json data.
npm ERR! package.json must be actual JSON, not just JavaScript.
npm ERR!
npm ERR! This is not a bug in npm.
npm ERR! Tell the package author to fix their package.json file. JSON.parse

npm ERR! System Linux 3.13.0-100-generic
npm ERR! command "/usr/bin/node" "/usr/bin/npm" "i"
npm ERR! cwd /bundle/bundle/programs/server
npm ERR! node -v v0.10.43
npm ERR! npm -v 1.4.29
npm ERR! file /bundle/bundle/programs/server/package.json
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR!     /bundle/bundle/programs/server/npm-debug.log
npm ERR! not ok code 0

=> Redeploying previous version of the app


To see more logs type 'mup logs --tail=50'


Your help will be appreciated.

You must use node 4.6.2 with Meteor Incidentally, the version of npm used with Meteor is 3.10.9. You may also need to change that.

1 Like

Thanks @robfallows you mean to say i’ve to change node version on server and npm version on server correct?


Possibly correct (haven’t tried a back-level npm).

ok thanks let me check whether it works or not.

1 Like

@robfallows Not able to install 4.6.2 on server. Error not Found. Do you have any source repository url from which i can install it.
Server OS : Ubuntu 14.04.5.

I installed 4.7.2 and tried mupx deploy but still throwing same error.

I tried with updating node and npm version but still facing same issue. :frowning:
@robfallows any other tweak ?

Have you checked the log?

Yes i checked. It also has same error.

Can you paste your package.json?

Just fix and got another issue. :frowning:
Fix: I created local build using meteor build command and move to the server folder and run mupx start. Might be issue of mupx bundle.

Issue : Deployment done. But not able to access the application. I tried using docker application IP as well as serve IP but it didn’t work.
Do you have any idea how I can access application from outside the network.