Deployment issue : module did not self-register


#1

Hi everyone,

I just rented a small sever at digitalocean and then I followed this tutorial to install meteor :

I understood what I did and everything went well.
Then when I first started the project, I got a nodejs version issue so I updated it to 4…
Then I got a fibers issue so I reinstalled it and now I get this :

Upstart log :

/home/[user]/bundle/programs/server/node_modules/fibers/future.js:267
throw(ex);
^
Error: Module did not self-register.
at Error (native)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at bindings (/home/[user]/bundle/programs/server/npm/node_modules/meteor/npm-bcrypt/node_modules/bcrypt/node_modules/bindings/bindings.js:76:44)
at Object. (/home/[user]/bundle/programs/server/npm/node_modules/meteor/npm-bcrypt/node_modules/bcrypt/bcrypt.js:3:35)
at Module._compile (module.js:460:26)
at Object.Module._extensions…js (module.js:478:10)
at Module.load (module.js:355:32)

First I tried to downgrade to nodejs 0.12 because that is what I use in development. I also tried to delete the node_module folder and npm reinstall/rebuild everything. And I just tried to reinstall bcrypt

I’m stuck and I am not sure what is the actual issue.

What should I do ?

rXp


#2

I manage to fix this error with :
cd /home/your_app_name/app/programs/server/npm/mode_modules/meteor/npm-bcrypt
npm install bcrypt

But now I don’t have any error in upstart or the app and everything is running BUT I still get an error 503 on http and an ERR_CONNECTION_REFUSED on https.

Why ? It should work now


#3

The same thing fixed it for me - but why??


#4

Same here for deploying 1.4. Followed the release notes, but no joy.

Dev box is a Mac, Prod box is a Linux x64


#5

I’m still having this issue. Has anyone a working solution? Currently I have to ssh into my server and manually rebuild the npm-bcrypt package which is really annoying.

Thanks in advance.


#6

Did you upgrade to the latest 1.4.0.1 version? It solved it for me if I deploy via pm2-meteor.


#7

The latest version 1.4.1 solved it for me!