Deployment with mup not working


#1

Hey guys,
just tried my first deployment with “mup” and yeah, I get a big error after “mup deploy”:

x Invoking deployment process: FAILED
-----------------------------------STDERR-----------------------------------
! System Linux 3.13.0-57-generic
gyp ERR! command “node” “/opt/nodejs/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js” “rebuild” "–release"
gyp ERR! cwd /opt/skeez/tmp/bundle/programs/server/node_modules/fibers
gyp ERR! node -v v0.10.36
gyp ERR! node-gyp -v v1.0.1
gyp ERR! not ok
Build failed

    npm ERR! fibers@1.0.5 install: `node ./build.js`
    npm ERR! Exit status 1
    npm ERR! 
    npm ERR! Failed at the fibers@1.0.5 install script.
    npm ERR! This is most likely a problem with the fibers package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR!     node ./build.js
    npm ERR! You can get their info via:
    npm ERR!     npm owner ls fibers
    npm ERR! There is likely additional logging output above.
    npm ERR! System Linux 3.13.0-57-generic
    npm ERR! command "/usr/bin/node" "/usr/bin/npm" "install"
    npm ERR! cwd /opt/skeez/tmp/bundle/programs/server
    npm ERR! node -v v0.10.36
    npm ERR! npm -v 1.4.28
    npm ERR! code ELIFECYCLE
    npm ERR! not ok code 0
    -----------------------------------STDOUT-----------------------------------
     > ./bcrypt: npm install due to binary npm modules
    bindings@1.0.0 node_modules/bindings

    nodeunit@0.9.1 node_modules/nodeunit
    └── tap@0.7.1 (inherits@2.0.1, buffer-equal@0.0.1, slide@1.1.6, deep-equal@1.0.0, yamlish@0.0.7, mkdirp@0.5.1, difflet@0.2.6, glob@4.5.3, runforcover@0.0.2, nopt@3.0.3)

    > fibers@1.0.5 install /opt/skeez/tmp/bundle/programs/server/node_modules/fibers
    > node ./build.js

Does anybody know what’s going wrong here?


#2

What kind of Linux system are you deploying to? Let’s see your mup.json file (be sure to obscure any sensitive data).


#3

Hey,
just fixed it - I used Ubuntu 12.04 LTS and upgraded to 14.04 LTS - now is everything working :smile:


#4

I use your subject. I have the same problem but i’m on windows server 2008. How can i resolve it ?