Disable meteor server retry?

Occasionally when visiting my meteor app I get a page that tells me to wait 15 seconds for the server to retry. I’m sure everyone gets this. How can I disable this feature?

By any chance are you using mup to deploy your application?

There’s a setting that let’s you toggle how long to wait after a deploy before your app is available. Check mup.json.

// Meteor Up checks if the app comes online just after the deployment
  // before mup checks that, it will wait for no. of seconds configured below
  "deployCheckWaitTime": 30 // seconds.

It’s not just after I deploy

well, if you are deploying to free meteor hosting service you need to count with that.
Inactive applications are shut down and started when there is some1 connecting.

I attempted to deploy one of my apps on a heroku server, however it failed. Can you direct me to an tutorial on doing this?

Everything I’ve read about Heroku mixing with Meteor leads to the same conclusion: Don’t.

But if you want to give it a shot use this buildpack.

And make sure you enable SessionAfinity.

@iwasserman, save yourself some headaches and just use something like a small DigitalOcean droplet. It’ll perform better, and work so well you will think something went wrong. mup is going to get you going in literally 5 minutes. (No hyperbole it’s just that easy).