Disable register {{> atForm}}

I’m using {{> atForm}} for login and register, and also these packages for users accounts-password accounts-base useraccounts:unstyled

[![enter image description here][1]][1]

I want to remove register possibilities for users.
It should be something in [this list][2], but i’m not sure what i’m supposed to override.
Can anyone help?


I also added this on the server,

        forbidClientAccountCreation : true

and it disabled the creation of users, but i need to remove it from the UI too, like u see in the picture.
[1]: http://i.stack.imgur.com/f2tpi.png
[2]: https://github.com/meteor-useraccounts/unstyled/tree/master/lib

Should be implemented: https://github.com/meteor-useraccounts/core/issues/15 but I think you need to make that setting also on the client, so in a shared file, or duplicated.

Here you can see the check: https://github.com/meteor-useraccounts/core/blob/37fde86da5eeee33465fd05a2c5dccb3fe16fed9/lib/templates_helpers/at_form.js#L46

and that file is included on the client only:

I just did this in the css. It will do for now thank you.

.at-signup-link {
    display none

I have added the following in my onRendered for the template containing the {{>atForm}}. I have a configuration collection so I can enable/disable account creation without having to push new code.

The below takes care of the social OAuth logins I have configured

Template.browserLogin.onRendered( function() {
	var c = Content.findOne({type:'AllowAccountCreation',active:true});
	if(c == undefined)

Why would you take this approach and not just put that official setting on both client and server as setup by Meteor?

Because the setting only disables account creation for passwords and not OAuth (in my experience). Also the setting is in the code, so in order to change it I must push new code.

        forbidClientAccountCreation : true

When done on Client and Server this definitely removes Don't Have an Account? Register on my site.

Ah clear, yes that’s difficult with social logins. They process signup and login almost equally.


hideSignUpLink: true


try this.

1 Like