Dockerize and Locally running meteor app is working fine but bundled code pushed to AWS ECR having problem

Hello guys. I just want to ask question about this problem I encountered.


  • I was able to build the meteor app using meteor build --directory --architecture os.linux.x86_64 ./build/
  • After that, I tried to run the dockerize app locally, and it worked fine
  • I build the meteor app in windows but inside WSL

so I was able to dockerize the meteor app locally using the bundle that the meteor build produces, I run it locally and its working fine but when I push it to AWS ECR and check the logs on the pod in the AWS EKS, there is an error (check the image). Just a background, I run meteor build in wsl specifying --architecture flag os.linux.x86_64 . The question is why am I having this problem when I deployed it versus not having that problem when I run docker locally? Is my flag pointing to Linux arch is correct or should I point it to windows?

Any help or idea will do. Thank you so much!

Reference Image:


We are already doing some tests with EKS.

As soon as I have feedback, I’ll get back to you by the slack thread.

Best Regards,

Philippe Oliveira

1 Like