Downgrade build src to meet hosting nodejs version


#1

Hi,

Have an app running using Meteor 1.6 (node 8.9).

The problem is my host provider maximum node version is 6.5.

Is there any solution to downgrade the app?
What was the Meteor version nodejs 6.5 compatible?

The best solution would be to downgrade the deployment code not the original.
App is tested to run after build/deployment to the local nodejs 8.9 env, but “npm start” fails on hosting service env (node 6.5) with:

/opt/repo/ROOT/programs/server/node_modules/fibers/future.js:280
throw(ex);
^
TypeError: Object.getOwnPropertyDescriptors is not a function

What’s more 'cd programs/server && npm install" seems to pass without errors on host (using node 6.5).

Any ideas?


#2

You’ll have to downgrade Meteor to 1.5
First go into .meteor/release inside your project and change it to METEOR@1.5
Then run meteor update --patch

That version of Meteor runs on Node 4.8.3 (and it should most preferrably be that exact version)

There is no version that runs on Node 6 btw


#3

Will give it a try, thanks.

… and has got:

Errors prevented startup:

While selecting package versions:
error: Potentially incompatible change required to top-level dependency: accounts-base 1.3.6, was 1.4.1.
Constraints on package “accounts-base”:

  • accounts-base@1.3.4 <- top level
  • accounts-base@~1.3.4 <- top level
  • accounts-base@1.2.14 <- service-configuration 1.0.11 <- accounts-base 1.3.6
  • accounts-base@1.3.6 <- accounts-password 1.4.2
  • accounts-base@1.3.0 <- accounts-facebook 1.2.1
  • accounts-base@1.2.14 <- accounts-oauth 1.1.15 <- accounts-facebook 1.2.1
  • accounts-base@1.3.0 <- accounts-google 1.2.0
  • accounts-base@1.0.0 <- ian:accounts-ui-bootstrap-3 1.2.89

Potentially incompatible change required to top-level dependency: accounts-password 1.4.2, was 1.5.0.
Constraints on package “accounts-password”:

  • accounts-password@1.4.0 <- top level
  • accounts-password@~1.4.0 <- top level
  • accounts-password@1.0.0 <- ian:accounts-ui-bootstrap-3 1.2.89

Potentially incompatible change required to top-level dependency: stylus 2.513.9, was 2.513.13.
Constraints on package “stylus”:

  • stylus@2.513.9 <- top level
  • stylus@~2.513.9 <- top level
  • stylus@1.0.0 || 2.0.0 <- ian:accounts-ui-bootstrap-3 1.2.89

To allow potentially incompatible changes to top-level dependencies, you must pass --allow-incompatible-update on the command line.


#5

Yeah, you’ve got a bunch of package versions that are too new I guess. I’m not sure what --allow-incompatible-update does exactly, maybe it sorts it out automatically? Otherwise you should be able to fix it by going into .meteor/packages and removing all the package versions (just leaving the package names). Or google to see what the recommended approach is.


#6

It seems it rolled back versions. Will push new build (1.5 based ) to host today.