Download meteor-tool problem


#1

When doing upgrading, it stuck at:
Downloading meteor-tool@1.3.2-rc.5… [ ] 0% 0.0s

tried ping warehouse.meteor.com according to others’ suggestions:

PING warehouse.meteor.com (146.88.128.224): 56 data bytes
64 bytes from 146.88.128.224: icmp_seq=0 ttl=39 time=320.706 ms
64 bytes from 146.88.128.224: icmp_seq=1 ttl=39 time=314.600 ms
64 bytes from 146.88.128.224: icmp_seq=2 ttl=39 time=311.657 ms
Request timeout for icmp_seq 3
64 bytes from 146.88.128.224: icmp_seq=4 ttl=39 time=311.771 ms
Request timeout for icmp_seq 5
64 bytes from 146.88.128.224: icmp_seq=6 ttl=39 time=311.522 ms
64 bytes from 146.88.128.224: icmp_seq=7 ttl=39 time=314.051 ms
64 bytes from 146.88.128.224: icmp_seq=8 ttl=39 time=727.359 ms
Request timeout for icmp_seq 9
64 bytes from 146.88.128.224: icmp_seq=10 ttl=39 time=311.187 ms

So my impression is this CDN connection is really bad, previous we didn’t have such problems for upgrading or installations.

Please fix this problem, as we can not use Meteor frame anymore .


#2

I first did an upgrade, and it failed multiple times.

After reading similar issue reports, I tried fresh installation, which worked.

After fresh install, start meteor, then it stuck at :
Downloading meteor-tool@1.3.2-rc.5… /

Well, fresh install worked, while downing the meteor-tool failed…

How can we keep working and investing time in the framework?

It was never such bad experience, before. Something has changed, the CDN has changed, and it didn’t work