Downloading meteor-tool@1.4.0-1


#1

I start my app by running meteor, and before it starts, it downloads the new version.

Downloading meteor-tool@1.4.0-1...        [========                  ] 30% 42.7s

So I wait. :confused:
When the download finishes, the app starts normally. After I stop the app, I see that it’s still version 1.3.5.1, so the project wasn’t updated, although the update was downloaded. I don’t quite understand the point of this.

If I execute meteor update right after that, it downloads the same thing again:

Downloading meteor-tool@1.4.0-1...       

And then it’s stuck forever.
(Windows 10, 64bit.)


#2

Same happens for me on OS X 10.11.5


#3

Happens here also =/


#4

same,but not only under windows 10, linux mint also


#5

Same here on OS X 10.11.5 too.


#6

linux: no joy either, but! after interrupting the download and logging out, I tried again and it did work after all


#7

After struggling for couple of days …IT WORKED FOR ME ==> 1.4.0.1

1 - clear cache .meteor , if it is not removed use ( peaZip manager tool to delete it by force )
2 - create a new meteor project
3 - add the packages one by one or divide them into small sets
a - figured out accounts-password is the problem
4 - shift your files to the new project
5 - install visual c++ build tools 2015 ( no need for VS )

I know this is may not be the perfect way, but at least this walk around gave me the solution


#8

same here on OSX. ubuntu 14 and c9.io enviroment


#9

Same here, every time I run tests, I get this (it completes, but it takes forever).


#10

Discovered a simple workaround that fixed this issue for me:

Run meteor update from a non-project folder.

Download completed. Then I was able to return to my project directory and successfully run meteor update there.

Cheers…


#11

Simply running meteor update fixed this for me.


#12

I have the same problem. I can’t run meteor project created in 1.4.0-1. It starts downloading meteor-tool and stops


#13

Same problem here.
Also i have been having this problem at each version change for months if not years.


#14

I’ve solved this problem and maybe it will also help you. I’ve just run meteor update outside of meteor project. After successful downloading the newest meteor tool I can now meteor update each project individually.


#15

Thank you, but il already tried that, with same result.


#16

Try > meteor update --patch


#17

I had the same issue. I had to create a new project and move and rename my original files into the newly created folder. Then it worked just fine without any update commands.


#18

Same happens for me on Windows 10 64 bit.I tried to run meteor update --patch and meteor update in and out of a project folder and did not work. I am unable to work with the Meteor. Can anyone help please?


#19

Try adding the following to your local hosts file (C:\Windows\System32\Drivers\etc\hosts):

54.192.225.217 warehouse.meteor.com 

Then run a meteor reset in your app directory (warning - will wipe your local DB), then try starting your app again.