Ejson error when installing semantic:ui


#1

I would like to install the less implementation of Semantic UI.
https://atmospherejs.com/semantic/ui

However when running meteor add semantic:ui I am faced with the following issue:

decider@d-i-00-0c-29-33-55-8e:~/outflank$ meteor add semantic:ui
     => Errors while adding packages:
    
    While selecting package versions:
    error: Conflict: Constraint ejson@1.0.6 is not satisfied by ejson 1.0.6-rc.0.
    Constraints on package "ejson":
    * ejson@=1.0.6-rc.0 <- top level
    * ejson@1.0.6-rc.0 <- meteor-platform 1.2.2-rc.0
    * ejson@1.0.6-rc.0 <- logging 1.0.7-rc.0 <- ddp 1.1.0-rc.1 <- accounts-base 1.2.0-rc.0 <- accounts-password 1.1.0-win.1
    * ejson@1.0.6-rc.0 <- logging 1.0.7-rc.0 <- ddp 1.1.0-rc.1 <- accounts-password 1.1.0-win.1
    * ejson@1.0.6-rc.0 <- logging 1.0.7-rc.0 <- meteor-platform 1.2.2-rc.0
    * ejson@1.0.6-rc.0 <- minimongo 1.0.7-rc.0 <- ddp 1.1.0-rc.1 <- accounts-base 1.2.0-rc.0 <- accounts-password 1.1.0-win.1
    * ejson@1.0.6-rc.0 <- minimongo 1.0.7-rc.0 <- ddp 1.1.0-rc.1 <- accounts-password 1.1.0-win.1
    * ejson@1.0.6-rc.0 <- minimongo 1.0.7-rc.0 <- meteorhacks:fast-render 2.7.1
    * ejson@1.0.6-rc.0 <- id-map 1.0.3-rc.0 <- binary-heap 1.0.3-rc.0 <- mongo 1.1.0-rc.0 <- accounts-base 1.2.0-rc.0 <- accounts-password 1.1.0-win.1
    * ejson@1.0.6-rc.0 <- id-map 1.0.3-rc.0 <- binary-heap 1.0.3-rc.0 <- mongo 1.1.0-rc.0 <- manuelschoebel:ms-seo 0.4.1
    * ejson@1.0.6-rc.0 <- id-map 1.0.3-rc.0 <- minimongo 1.0.7-rc.0 <- meteorhacks:fast-render 2.7.1
    * ejson@1.0.6-rc.0 <- ddp 1.1.0-rc.1 <- accounts-base 1.2.0-rc.0 <- accounts-password 1.1.0-win.1
    * ejson@1.0.6-rc.0 <- ddp 1.1.0-rc.1 <- accounts-password 1.1.0-win.1
    * ejson@1.0.6-rc.0 <- check 1.0.5-rc.0 <- accounts-base 1.2.0-rc.0 <- accounts-password 1.1.0-win.1
    * ejson@1.0.6-rc.0 <- check 1.0.5-rc.0 <- accounts-password 1.1.0-win.1
    * ejson@1.0.6-rc.0 <- mongo 1.1.0-rc.0 <- accounts-base 1.2.0-rc.0 <- accounts-password 1.1.0-win.1
    * ejson@1.0.6-rc.0 <- mongo 1.1.0-rc.0 <- manuelschoebel:ms-seo 0.4.1
    * ejson@1.0.6-rc.0 <- session 1.1.0-rc.0 <- meteor-platform 1.2.2-rc.0
    * ejson@1.0.6-rc.0 <- reactive-dict 1.1.0-rc.0 <- aldeed:autoform 5.3.2
    * ejson@1.0.2 <- iron:router 1.0.9
    * ejson@1.0.2 <- iron:core 1.0.8 <- iron:controller 1.0.8 <- iron:router 1.0.9
    * ejson@1.0.2 <- iron:core 1.0.8 <- iron:router 1.0.9
    * ejson@1.0.3 || 1.0.4 || 1.0.4 <- aldeed:autoform 5.3.2
    * ejson@1.0.6-rc.0 <- accounts-base 1.2.0-rc.0 <- accounts-password 1.1.0-win.1
    * ejson@1.0.3 <- meteorhacks:fast-render 2.7.1
    * ejson@1.0.3 <- meteorhacks:inject-data 1.3.0 <- meteorhacks:fast-render 2.7.1
    * ejson@1.0.4 <- cfs:base-package 0.0.30 <- cfs:access-point 0.1.49 <- cfs:standard-packages 0.5.9
    * ejson@1.0.4 <- cfs:base-package 0.0.30 <- cfs:filesystem 0.1.2
    * ejson@1.0.4 <- cfs:storage-adapter 0.2.2 <- cfs:file 0.1.17 <- cfs:access-point 0.1.49 <- cfs:standard-packages 0.5.9
    * ejson@1.0.4 <- cfs:storage-adapter 0.2.2 <- cfs:file 0.1.17 <- cfs:standard-packages 0.5.9
    * ejson@1.0.4 <- cfs:storage-adapter 0.2.2 <- cfs:filesystem 0.1.2
    * ejson@1.0.4 <- cfs:data-man 0.0.6 <- cfs:file 0.1.17 <- cfs:access-point 0.1.49 <- cfs:standard-packages 0.5.9
    * ejson@1.0.4 <- cfs:data-man 0.0.6 <- cfs:file 0.1.17 <- cfs:standard-packages 0.5.9
    * ejson@1.0.4 <- cfs:access-point 0.1.49 <- cfs:standard-packages 0.5.9
    * ejson@1.0.4 <- cfs:http-methods 0.0.29 <- cfs:access-point 0.1.49 <- cfs:standard-packages 0.5.9
    * ejson@1.0.4 <- cfs:http-publish 0.0.13 <- cfs:access-point 0.1.49 <- cfs:standard-packages 0.5.9
    * ejson@1.0.4 <- meteorhacks:kadira 2.22.1
    * ejson@1.0.6 <- semantic:ui 2.0.7

Does anyone have any ideas?


#2

Could you list your packages and paste here please.

Meteor list or the contents of versions inside .meteor will do :smile:


#3

Thanks for the reply, it seems creating a new meteor app and moving my code and package list over to the new app has solved the issue.