ElasticBeanstalk Bcrypt issue

Hey guys, loving MeteorJS so far. Perhaps those who have deployed to EB might be able to help me out.

I was able to deploy my app to EB successfully, however subsequent deployments are failing. During the npm install phase, I get an error message like so

` gyp ERR! node -v v0.10.42
gyp ERR! node-gyp -v v1.0.1
gyp ERR! not ok

npm ERR! bcrypt@0.8.5 install: node-gyp rebuild
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the bcrypt@0.8.5 install script.
npm ERR! This is most likely a problem with the bcrypt package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-gyp rebuild
npm ERR! You can get their info via:
npm ERR! npm owner ls bcrypt
npm ERR! There is likely additional logging output above.
npm ERR! System Linux 4.1.17-22.30.amzn1.x86_64
npm ERR! command “/opt/elasticbeanstalk/node-install/node-v0.10.42-linux-x64/bin/node” “/opt/elasticbeanstalk/node-install/node-v0.10.42-linux-x64/bin/npm” “–production” "rebuild"
npm ERR! cwd /tmp/deployment/application
npm ERR! node -v v0.10.42
npm ERR! npm -v 1.4.29
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /tmp/deployment/application/npm-debug.log
npm ERR! not ok code 0
Running npm install: /opt/elasticbeanstalk/node-install/node-v0.10.42-linux-x64/bin/npm
Setting npm config jobs to 1

I am using the iron CLI to build my app. The script I’m using to deploy looks a bit like this:

`rm -Rf build/bundle

iron build --server=https://my-domain.com --architecture os.linux.x86_64

eb deploy prod

package.json at the root of the project looks like this:

{ "name": "trail-status", "version": "2.0.0", "scripts": { "start": "node build/bundle/main.js" }, "dependencies": { "fibers": "1.0.1", "underscore": "*", "source-map-support": "*", "semver": "*", "bcrypt": "*" } }

I’ve tried removing build/bundle/programs/server/npm/npm-bcrypt/node_modules/bcrypt without much luck. Also have tried removing bcrypt from the package.json.

What OS are you building on?

bcrypt is only needed if you’ve built on a different platform, like a mac, and consequently had to remove the bundle/programs/server/npm/npm-bcrypt directory.

I was building on a Mac, but the --architecture flag should build it for the arch of my server no?