Error after 'meteor add accounts-password'


#1

Getting a very extensive error after ‘meteor add accounts-password’. Toward the end of the error terminal outputs this:

node v4.4.7
npm  v3.10.5
code ELIFECYCLE
bcrypt@0.7.7 install: `node-gyp rebuild`
Exit status 1

Failed at the bcrypt@0.7.7 install script 'node-gyp rebuild'.
Make sure you have the latest version of node.js and npm installed.
If you do, this is most likely a problem with the bcrypt package,
not with npm itself.
Tell the author that this fails on your system:
    node-gyp rebuild
You can get information on how to open an issue for this project with:
    npm bugs bcrypt

I’ve seen a similar topic on the forums, but triggered only for Windows users, while I am on a mac. Should I downgrade meteor? Thanks.


#2

Check the Guide notes for OS X:

OS X users should install the commandline tools (in short, run xcode-select --install).

To test that your compiler toolchain is installed and working properly, try installing any binary npm package in your application using meteor npm. For example, run meteor npm install bcrypt then meteor node, then try calling require("bcrypt") from the Node shell.


#3

@robfallows thanks, but no luck. It appears to be a bug, doesn’t it?


#4

I don’t know - I don’t use OS X, so have no chance of trying to reproduce this.

There seem to be a couple of issues tracking this - one seems more Windows related, the other also seems to affect OS X users:

There may be a solution in one of those which helps.

EDIT: If not, perhaps you can add to the conversation and help find a solution :slight_smile:


#5

Thanks for posting those! Unfortunately, they’re for errors on Windows but I will poke around to see if there’s anything applicable for me.


#6

Welp, after many varied attempts, I believe using meteor add npm-bcrypt solved it.


#7

Tried everything, still can’t get meteor-accounts / meteor-password to work due to this bcrypt error on Windows. When I try to install the windows build tools it installs python and then just doesn’t download anything and leaves me hanging. Left it overnight and tried multiple times. Really sad that such a huge error would just pop up out of nowhere and no support to fix it.

Really makes me think about leaving Meteor for good.


#8

I had this issue on my Windows 2012 R2 server. I solved it by opening up PowerShell (admin) and typing npm install --global --production windows-build-tools


#9

Stuck like this for days:


#10

I had a similar problem. Check out my entry in I get errors when in command line: meteor add accounts-password


#11

Find your way to packages and delete accounts-password folder and try to run the command again. This worked for me.


#12

“meteor add npm-bcrypt” was my solution…!!