Error deploying Meteor in production mode - Fibers cannot install


#1

I’m able to run Meteor just fine in development mode but the moment I switch to a production deploy I get the following error:

npm ERR! fibers@1.0.5 install: node ./build.js
npm ERR! Exit status 127
npm ERR!
npm ERR! Failed at the fibers@1.0.5 install script.
npm ERR! This is most likely a problem with the fibers package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node ./build.js
npm ERR! You can get their info via:
npm ERR! npm owner ls fibers
npm ERR! There is likely additional logging output above.
npm ERR! System Linux 3.0.101-0.46-default
npm ERR! command “/root/.nvm/v0.10.36/bin/node” “/root/.nvm/v0.10.36/bin/npm” "install"
npm ERR! node -v v0.10.36
npm ERR! npm -v 1.4.28
npm ERR! code ELIFECYCLE
npm ERR! not ok code 0

Help?


#2

Questions:

  1. What’s the command you’re using that gives you that output? meteor build?
  2. Usually when npm fails it gives you additional logging output at npm-debug.log (or similar, in the project directory). Is there one, and if so, does it contain anything useful that we don’t know yet?
  3. I’m not 100% sure but npm version 1.4.x and Linux 3.0.x sounds terribly out of date – though npm 1.4.x might be the highest one can get on node 0.10.x, I’m not sure right now. Is that an Ubuntu 12.04 LTS or something? So one thing to try could be to use up to date node, npm and Kernel, but that should probably not be the first thing to do since it’s not very likely that this is actually really part of the problem here… and might be much more work than other options.

#3

Hi Seeekr, thanks for the help!

I was able to find a linux guru at my company and we worked out the issue together.

It was related to my use of NVM for managing my node versions. The fiber install script was running under the user “nobody” and NVM wasn’t granting “nobody” execution privileges.


#4

You’re welcome, glad you worked it out!