Error installing fibers@2.0.0 on Ubuntu 14 EC2

I have a Meteor --bare 1.6.1 running localling fine. But when I go to deploy to a EC2 instance I run into issues.

Basically, I stood up a brand new Ubuntu 14 EC2 instance. I ran the MUP (non-docker/older) script I’ve been using for a long time now and I’m getting an error on deployment.

Node and Mongo have been installed fine.

The issue seems to be the script, and I cannot manually, install fibers@2.0.0 on the server.

I’m logged in as ubuntu here:

> sudo npm install -g fibers@2.0.0

This is the console:

Logged in as root and running the same npm command as above I get a loopback that doesn’t end:

Here are the versions I’m running on the EC2 server:


A couple of red flags:

‘sudo npm install’ is not good practice. If you installed node with ‘sudo apt-get’ then that explains it, but it also might explain the permission error that I see in the first screenshot (EACCESS…).

Do not do anything pertaining to Node as root. There are many reasons for that, which you can easily read about online.

NVM has you covered. It’s easy and elegant. Give it a try. It should solve your problem.


I couldn’t get Meteor 1.6.1 to properly install with MUP classic (I’ve been using it for years), so I switched to PM2 and loved the experiance. So much easier.

1 Like