Error: /lib64/ version `GLIBCXX_3.4.20' not found



I just updated my project to 1.3.2 then I ran meteor build ~/ui --directory thenI set all environment variables needed
and when I run node main.js

I got this error:

Module._extensions[extension](this, filename);
Error: /lib64/ version `GLIBCXX_3.4.20’ not found (required by /home/centos7/ui/bundle/programs/server/node_modules/fibers/bin/linux-x64-v8-3.14/fibers.node)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object. (/home/centos7/ui/bundle/programs/server/node_modules/fibers/fibers.js:20:37)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)

the first thing that I did after seeing this error was to check if that library exists and it does

# ls -lash /lib64/
0 lrwxrwxrwx. 1 root root 19 Apr  1 11:02 /lib64/ ->

does anyone has run into this problem and/or has found a solution for this?

thanks for any help or hint :slight_smile:


Having the same issue here, while deploying meteor build onto a centos 7 vm.
Any suggestion?


Hi @Voidmen I fixed this problem by building the bundle in the same OS than your target,

in this case you should run meteor build in a CentOS 7


Thanks!Will try it out.



Has anyone found a fix for this issue? I just upgraded to Meteor 1.6 and am now seeing this error when I attempt to run the built project on AWS Elastic Beanstalk. I tried upgrading my Node version from 4.8.4 to 8.4.0 (the latest version AWS EB has available). I didn’t have this issue prior to Meteor version 1.6.

I also tried using a few other Node builds on AWS but nothing seems to be working.

Any help would be greatly appreciated. Thanks!


Timely regurgitation… :slight_smile:

I’m also scratching my head on this with 1.6. Building on ubuntu 16.04 (in a docker image with node 8.9.1). When deploying and running on another ubuntu docker image, no problems. But when deploying on CentOS 7, bang!

Any suggestions (except for having a separate build box for each deployment platform)?


(Error: /lib64/ version `GLIBCXX_3.4.20’ not found)


sudo add-apt-repository ppa:ubuntu-toolchain-r/test
sudo apt-get update
sudo apt-get install gcc-4.9
sudo apt-get upgrade libstdc++6

strings /usr/lib/x86_64-linux-gnu/ | grep GLIBCXX