Error 'meteorInstall' on IE11

Hi every body,

I’ve error Javascript when i open my Meteor APP on IE11 (only) :

Unable to get the property 'meteorInstall' a null reference or undefined

At this line :

var meteorInstall = Package.modules.meteorInstall;

Do you have any idea for fix it ?

Thank you !

1 Like

Up :slight_smile:

No one has the problem ?

Do you have the ecmascript package added to your project? If not try the following:

meteor add ecmascript

Hi @hwillson

Yep, ecmascript@0.5.7 in my packages.

This is a real pain point and a bunch of users are suffering from this. Not sure what Meteor version you’re running but see https://github.com/meteor/meteor/issues/10658#issuecomment-521788051 I am sure there a re a bunch of other similar issues out there too…

We really need help on this @robfallows @benjamn pretty please

wondering if you solved this?

1 Like

This a very generic error and is usually caused by modern syntax not recognized by IE.

You really need to narrow down on the culprit package and see why it’s not running in IE.

Edit: sorry I noticed the author mentions the exact line, but make sure there are no previous errors that could lead to this.

@alawi in addition to the circular import isseu https://github.com/meteor/meteor/issues/10679 , I found one culprit so far JSONATA they mention in ES5 file in the issue below… any guidance on how to get around this please?

1 Like

I’m glad you narrowed down the issue but I’m not really aware of this specific library. I personally managed to push our only client using IE to stop using it but I know this is not an option for everyone.

thanks @alawii got it to work with a symbolic link … back on Meteor 1.8.1

1 Like

Great, might want to close that github issue.

I closed the jsonata one. But as far as I am aware the circular reference one still exists. Unless you think that should not be allowed?

I went through a big refactor - updating packages and shifting to react hooks, and came up with this dreaded error!

You really need to narrow down on the culprit package

Any tips on how to go about narrowing down the culprit? IE devtools are zero help (I’ve spent a day setting up a virtual Windows 10 machine to get the IE environment going, along with installing and setting up Meteor on the VM).

image

Urghhhh, IE!

1 Like

Jump to that line in modules and check what’s going on there.
Had a similar issue last week which was solvable by downgrading simple schema as the lib uses class syntax in the latest version which is not supported by ie11.

2 Likes

Specifically v1.5.5 is the last correctly compiled version of simpl-schema.
You can pin it with npm install simpl-schema@1.5.5. Be sure to commit your package-lock.json as well to ensure it uses the right version.

I’ve got a PR in to fix the incorrect compilation for browsers.

1 Like

Simpl Schema was indeed the issue. Adding this to package.json fixed it:

 "meteor": {
    "mainModule": {
      "client": "./client/main.js",
      "server": "./server/main.js"
    },
    "nodeModules": {
      "recompile": {
        "simpl-schema": "legacy",
        "query-string": "legacy"       
      }
    }
  },
1 Like

Got the same error; for me it was the ‘rough-notation’ package. Removed it; my meteor flies though the heavens once again! :slight_smile: