Error on cli use

Hi, I installed meteor and was having really long build times, so tried to install globally via npm (which I now realize wasn’t a good idea) and then tried re-installing via windows installer.

All I have now is a broken CLI. Typing “meteor” by itself or with any params I get:

    throw err;

Error: Cannot find module 'C:\Users\Andrew\AppData\Roaming\npm\node_modules\meteor\app\meteor\meteor.js'
    at Function.Module._resolveFilename (module.js:339:15)
    at Function.Module._load (module.js:290:25)
    at Function.Module.runMain (module.js:447:10)
    at startup (node.js:140:18)
    at node.js:1001:3

Any suggestions?

Just solved this for myself.

Go to the C:\Users\user\AppData\Roaming\npm and rename meteor and meteor.cmd to old.meteor and old.meteor.cmd and ensure that you have successfully added an environment variable that points Meteor to C:\Users\user\AppData\Local.meteor



This worked for me too. Thanks!

I had issues with terribly long (sometimes seemingly infinite/stuck) build times on Windows as well. My solution was switching to Linux. Windows was always the least prioritized platform by Meteor and didn’t have official support at all for a long time, so I figured it was just safer to switch to Linux.