Error trying to meteor run android-device


I built a fresh meteor app (meteor create) and tried to run it via android device. I am getting this error:

nigels-iMac:test nigelpasco$ meteor run android-device
[[[[[ ~/meteor/test ]]]]]                     

=> Started proxy.                             
=> Started MongoDB.                           
=> Errors executing Cordova commands:                                           
   While adding plugin                                                    
   to Cordova project:
   Cordova error: Failed to fetch plugin                                   via git.
   Either there is a connection problems, or plugin spec is incorrect:
   Error: git: Command failed with exit code 69 Error output:
   Agreeing to the Xcode/iOS license requires admin privileges, please re-run
   as root via sudo.
   (If the error message contains suggestions for a fix, note that this may not 
   apply to the Meteor integration. You can try running again with the
   --verbose option to help diagnose the issue.)


I have looked through similar issues without resolution. I have installed android SDK and installed version 22. I have tried via sudo.

I am running the latest meteor V1.2.1.

Can somebody please confirm that meteor run android-device should work on a fresh install. Or, offer any work around.

Thank you.

This is a little obscure, but Cordova uses Git to download some plugins. And on a Mac, using Git requires the command line build tools (or the full Xcode) to be installed. You will also have to accept the license however. If you startup Xcode for the first time it will prompt you to do so. A shortcut is to run sudo xcodebuild -license accept from the command line.