Error when creating a project on Mac

When I run in my terminal “meteor create new_app”,

I get the following error:

throw error;

Error: can’t get arch with uname -p?
at run (/tools/utils/archinfo.js:151:15)
at (/tools/utils/archinfo.js:161:11)
at ProjectContext.reset (/tools/project-context.js:94:45)
at new ProjectContext (/tools/project-context.js:60:8)
at Command.func (/tools/cli/commands.js:769:24)
at /tools/cli/main.js:1531:15

It then creates the project folder, but if I cd into the project folder and run “meteor” in the terminal to run the project, nothing runs and I get the an error about there being a missing release file. when I add the release file and re-run, I get the same error posted above.

I have tried reinstalling meteor, and I have it installed using the script from the official website.

Does anybody have any guidance that can help me? Thank you so much!

Hi, Make sure to set up your Mac for development.

Sounds like you might have issues with your $PATH?

What happens if you try to run uname -p in a terminal?

This should 100% work out of the box. Also, this isn’t really helpful advice

Running uname -p returns “i386” in the terminal. I am not sure exactly what that means/where to go from there. Thank you for helping me look into this.

You could try following this SO post.

I don’t think this is related to my issue