Error when trying to update to 1.4


#1

Trying to update from 1.3.2.4 to 1.4

meteor update --release 1.4.0.1
=> Errors while initializing project:

While loading package fourseven:scss@3.3.3_3:
error: Command failed: /Users/minminsanjose/.meteor/packages/meteor-tool/.1.4.0-1.1an9pyn++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/dev_bundle/bin/npm rebuild --no-bin-links --update-binary
module.js:327
throw err;
^

Error: Cannot find module '…/'
at Function.Module._resolveFilename (module.js:325:15)
at Function.Module._load (module.js:276:25)
at Module.require (module.js:353:17)
at require (internal/module.js:12:17)
at Object.
(/Users/minminsanjose/.meteor/packages/fourseven_scss/.3.3.3_3.azn3ui++os.osx.x86_64+web.browser+web.cordova/plugin.compileScssBatch.os.osx.x86_64/npm/node_modules/meteor/compileScssBatch/compileScssBatch/node_modules/.temp-1jxdikq/node_modules/node-sass/node_modules/cross-spawn/node_modules/spawn-sync/node_modules/try-thread-sleep/node_modules/thread-sleep/node_modules/.bin/node-pre-gyp:15:20)
at Module._compile (module.js:409:26)
at Object.Module._extensions…js (module.js:416:10)
at Module.load (module.js:343:32)
at Function.Module._load (module.js:300:12)
at Function.Module.runMain (module.js:441:10)

npm ERR! Darwin 15.5.0
npm ERR! argv “/Users/minminsanjose/.meteor/packages/meteor-tool/.1.4.0-1.1an9pyn++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/dev_bundle/bin/node”
"/Users/minminsanjose/.meteor/packages/meteor-tool/.1.4.0-1.1an9pyn++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/dev_bundle/bin/npm" “rebuild” “–no-bin-links” "–update-binary"
npm ERR! node v4.4.7
npm ERR! npm v3.10.5
npm ERR! code ELIFECYCLE
npm ERR! thread-sleep@1.0.4 install: node-pre-gyp install --fallback-to-build
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the thread-sleep@1.0.4 install script ‘node-pre-gyp install --fallback-to-build’.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the thread-sleep package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-pre-gyp install --fallback-to-build
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs thread-sleep
npm ERR! Or if that isn’t available, you can get their info via:
npm ERR! npm owner ls thread-sleep
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!
/Users/minminsanjose/.meteor/packages/fourseven_scss/.3.3.3_3.azn3ui++os.osx.x86_64+web.browser+web.cordova/plugin.compileScssBatch.os.osx.x86_64/npm/node_modules/meteor/compileScssBatch/compileScssBatch/node_modules/.temp-1jxdikq/npm-debug.log
module.js:327
throw err;
^

Error: Cannot find module '…/'
at Function.Module._resolveFilename (module.js:325:15)
at Function.Module._load (module.js:276:25)
at Module.require (module.js:353:17)
at require (internal/module.js:12:17)
at Object.
(/Users/minminsanjose/.meteor/packages/fourseven_scss/.3.3.3_3.azn3ui++os.osx.x86_64+web.browser+web.cordova/plugin.compileScssBatch.os.osx.x86_64/npm/node_modules/meteor/compileScssBatch/compileScssBatch/node_modules/.temp-1jxdikq/node_modules/node-sass/node_modules/cross-spawn/node_modules/spawn-sync/node_modules/try-thread-sleep/node_modules/thread-sleep/node_modules/.bin/node-pre-gyp:15:20)
at Module._compile (module.js:409:26)
at Object.Module._extensions…js (module.js:416:10)
at Module.load (module.js:343:32)
at Function.Module._load (module.js:300:12)
at Function.Module.runMain (module.js:441:10)

npm ERR! Darwin 15.5.0
npm ERR! argv “/Users/minminsanjose/.meteor/packages/meteor-tool/.1.4.0-1.1an9pyn++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/dev_bundle/bin/node”
"/Users/minminsanjose/.meteor/packages/meteor-tool/.1.4.0-1.1an9pyn++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/dev_bundle/bin/npm" “rebuild” “–no-bin-links” "–update-binary"
npm ERR! node v4.4.7
npm ERR! npm v3.10.5
npm ERR! code ELIFECYCLE
npm ERR! thread-sleep@1.0.4 install: node-pre-gyp install --fallback-to-build
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the thread-sleep@1.0.4 install script ‘node-pre-gyp install --fallback-to-build’.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the thread-sleep package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-pre-gyp install --fallback-to-build
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs thread-sleep
npm ERR! Or if that isn’t available, you can get their info via:
npm ERR! npm owner ls thread-sleep
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!
/Users/minminsanjose/.meteor/packages/fourseven_scss/.3.3.3_3.azn3ui++os.osx.x86_64+web.browser+web.cordova/plugin.compileScssBatch.os.osx.x86_64/npm/node_modules/meteor/compileScssBatch/compileScssBatch/node_modules/.temp-1jxdikq/npm-debug.log

Also meteor npm install gives:

meteor npm install
/Users/minminsanjose/.meteor/packages/meteor-tool/.1.4.0-1.1an9pyn++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/tools/cli/dev-bundle.js:113
throw e;
^

Error: ELOOP: too many symbolic links encountered, stat '/Users/minminsanjose/.meteor/.meteor/package-metadata’
at Error (native)
at Object.fs.statSync (fs.js:844:18)
at statOrNull (/Users/minminsanjose/.meteor/packages/meteor-tool/.1.4.0-1.1an9pyn++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/tools/cli/dev-bundle.js:110:19)
at /Users/minminsanjose/.meteor/packages/meteor-tool/.1.4.0-1.1an9pyn++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/tools/cli/dev-bundle.js:151:12
at find (/Users/minminsanjose/.meteor/packages/meteor-tool/.1.4.0-1.1an9pyn++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/tools/cli/dev-bundle.js:137:9)
at getDevBundleForRelease (/Users/minminsanjose/.meteor/packages/meteor-tool/.1.4.0-1.1an9pyn++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/tools/cli/dev-bundle.js:63:28)
at getDevBundleDir (/Users/minminsanjose/.meteor/packages/meteor-tool/.1.4.0-1.1an9pyn++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/tools/cli/dev-bundle.js:44:10)
at Object. (/Users/minminsanjose/.meteor/packages/meteor-tool/.1.4.0-1.1an9pyn++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/tools/cli/dev-bundle.js:172:18)
at Module._compile (module.js:409:26)
at Object.Module._extensions…js (module.js:416:10)


#2

Did you find a solution? I’m seeing exactly the same error…


#3

You should try to figure out which package you are using which depends on (or if you depend directly on yourself) fourseven:scss. That version is terribly old and has known, confirmed issues with Meteor 1.4 – just search Issues and you’ll see it on a regular basis. I recommend trying to run:

meteor add fourseven:scss@3.8.0_1

And see what it does for you. (Then run meteor list and look for other packages which are outdated– the ones with the stars *!).

Remember: Updating Meteor involves updating all the packages you depend on (and your dependencies depend on, even if this means contacting those package authors!).


#4

Have you solve this problem, I’m getting the same error. I will try @abernix solution.

EDIT

When I try to meteor add fourseven:scss@3.8.0_1 I get the following:

$ meteor add fourseven:scss@3.8.0_1
 => Errors while adding packages:             
                                              
While selecting package versions:
error: Conflict: Constraint caching-compiler@1.0.5_1 is not satisfied by caching-compiler 1.0.5.
Constraints on package "caching-compiler":
* caching-compiler@=1.0.5 <- top level
* caching-compiler@1.0.4 <- caching-html-compiler 1.0.6 <- angular-templates-runtime 0.0.1 <- angular-templates 1.0.3
* caching-compiler@1.0.5 <- coffeescript 1.1.1 <- lepozepo:cloudinary 4.2.2
* caching-compiler@1.0.5 <- less 2.6.2 <- velocity:html-reporter 0.10.1
* caching-compiler@1.0.5_1 <- fourseven:scss 3.8.0_1

Conflict: Constraint ecmascript@0.4.6_1 is not satisfied by ecmascript 0.4.5.
Constraints on package "ecmascript":
* ecmascript@=0.4.5 <- top level
* ecmascript@0.4.4 <- webapp 1.2.9 <- autoupdate 1.2.10 <- hot-code-push 1.0.4 <- meteor-base 1.0.4
* ecmascript@0.4.4 <- webapp 1.2.9 <- meteor-base 1.0.4
* ecmascript@0.4.5 <- random 1.0.10 <- accounts-base 1.2.8 <- accounts-password 1.1.11
* ecmascript@0.4.5 <- random 1.0.10 <- accounts-password 1.1.11
* ecmascript@0.4.3 <- webapp-hashing 1.0.9 <- webapp 1.2.9 <- autoupdate 1.2.10 <- hot-code-push 1.0.4 <- meteor-base 1.0.4
* ecmascript@0.4.3 <- webapp-hashing 1.0.9 <- webapp 1.2.9 <- meteor-base 1.0.4
* ecmascript@0.4.5 <- ddp-server 1.2.8 <- ddp 1.2.5 <- accounts-base 1.2.8 <- accounts-password 1.1.11
* ecmascript@0.4.5 <- ddp-server 1.2.8 <- ddp 1.2.5 <- accounts-password 1.1.11
* ecmascript@0.4.5 <- mongo 1.1.9
* ecmascript@0.4.4 <- allow-deny 1.0.5 <- mongo 1.1.9
* ecmascript@0.4.4 <- http 1.1.6
* ecmascript@0.4.3 <- caching-html-compiler 1.0.6 <- angular-templates-runtime 0.0.1 <- angular-templates 1.0.3
* ecmascript@0.4.4 <- caching-compiler 1.0.5 <- caching-html-compiler 1.0.6 <- angular-templates-runtime 0.0.1 <- angular-templates
1.0.3
* ecmascript@0.4.4 <- caching-compiler 1.0.5 <- coffeescript 1.1.1 <- lepozepo:cloudinary 4.2.2
* ecmascript@0.4.4 <- caching-compiler 1.0.5 <- fourseven:scss 3.8.0_1
* ecmascript@0.4.3 <- templating-tools 1.0.4 <- angular-templates-runtime 0.0.1 <- angular-templates 1.0.3
* ecmascript@0.1.6 <- angular-templates-runtime 0.0.1 <- angular-templates 1.0.3
* ecmascript@0.4.1 <- sanjo:jasmine 1.0.1
* ecmascript@0.4.5 <- templating 1.1.11 <- launch-screen 1.0.12 <- mobile-experience 1.0.4
* ecmascript@0.4.5 <- templating 1.1.11 <- lepozepo:cloudinary 4.2.2
* ecmascript@0.4.5 <- coffeescript 1.1.1 <- lepozepo:cloudinary 4.2.2
* ecmascript@0.4.1 <- velocity:reports 1.0.0 <- sanjo:jasmine 1.0.1
* ecmascript@0.4.1 <- velocity:html-reporter 0.10.1
* ecmascript@0.4.5 <- less 2.6.2 <- velocity:html-reporter 0.10.1
* ecmascript@0.4.4 <- reactive-dict 1.1.8 <- meteortoys:toykit 3.0.4 <- msavin:mongol 2.0.1
* ecmascript@0.4.6_1 <- fourseven:scss 3.8.0_1
* ecmascript@0.4.5 <- accounts-password 1.1.11
* ecmascript@0.4.5 <- accounts-base 1.2.8 <- accounts-password 1.1.11