Error while updating Meteor 1.8.0.2


#1

Hi,
when I run the command meteor update, i am getting the error
`=> Errors while initializing project:

While selecting package versions:
error: No version of mongo satisfies all constraints: @1.6.0, @=1.5.0, @~1.6.0
Constraints on package “mongo”:

  • mongo@1.6.0 <- top level
  • mongo@=1.5.0 <- top level
  • mongo@~1.6.0 <- top level
  • mongo@1.6.0 <- accounts-base 1.4.3 <- accounts-google 1.3.2
  • mongo@1.1.14 <- service-configuration 1.0.11
  • mongo@1.5.0 <- oauth 1.2.6
  • mongo@1.5.0 <- reactive-dict 1.2.1
  • mongo@1.0.8 <- tmeasday:presence 1.0.6
  • mongo@1.1.7 <- mongo-livedata 1.0.12 <- meteorhacks:kadira 2.5.0
  • mongo@1.6.0 <- autoupdate 1.5.0 <- hot-code-push 1.0.4 <- meteor-base 1.4.0
  • mongo@1.1.1 <- easysearch:core 2.0.0 <- easy:search 2.2.0
  • mongo@1.1.14 <- easysearch:components 2.2.2 <- easy:search 2.2.0
  • mongo@1.0.8 <- kadira:debug 2.0.0
  • mongo@1.1.2 <- johanbrook:publication-collector 1.0.9
  • mongo@1.1.12_2 <- facts 1.0.9
  • mongo@1.0.8 <- sakulstra:aggregate 1.4.3`

can somebody help me to solve the problem,


#2

it fixed, the reason for this error was Mongo Driver for @1.5.0 was added inside the codebase