Exited from signal: SIGSEGV

Company which i work for have bought system, and one part of system is running on meteor.

Problem is that meteor versions is quite old 1.4.3, and i have tried to update it to 1.9, but it didnt work well - launching app took hours, and since im not familiar with meteor, i couldnt find the problem, but thats not the main problem ( upgrading atm is moved to later time ).

Main problem is that its working on production server, but when i launch exactly the same code on local machine, other remote server, docker container, i have same error: after logging into system, i get “Exited from signal: SIGSEGV”, and i cant find anything related on google and stackoverflow, only that its segmentation fault, and i dont get what could cause it - im running ubuntu 18.04 with 16gb of ram, 8gb swap, which should be enough.

Can databases cause SIGSEGV error? this project is using postgresql, mongodb and redis - can any of those cause such problem?

I need some suggestions in which direction i should dig? Is any additional information needed?

How are you launching it on your local computer?

with shell script

export MONGO_URL=mongodb........
meteor --port 2044 --settings settings.json

settings.json contains redis, postgres and ftp ip and credentials

Is there a stack trace to go along with that error?

thats the problem, i cant trace which part is failing