"Failed to install dependency kit." Meteor Universal

I followed the tutorial here but after I finished the git download and tried to run meteor for the first time, it failed to download the dependency kit.

`root@raspberrypi:/tmp# $HOME/meteor/meteor create --example todos
It’s the first time you’ve run Meteor from a git checkout.
I will download a kit containing all of Meteor’s dependencies.

curl: (60) SSL certificate problem: unable to get local issuer certificate
More details here: http://curl.haxx.se/docs/sslcerts.html

curl performs SSL certificate verification by default, using a "bundle"
of Certificate Authority (CA) public keys (CA certs). If the default
bundle file isn’t adequate, you can specify an alternate file
using the --cacert option.
If this HTTPS server uses a certificate signed by a CA represented in
the bundle, the certificate verification probably failed due to a
problem with the certificate (it might be expired, or the name might
not match the domain name in the URL).
If you’d like to turn off curl’s verification of the certificate, use
the -k (or --insecure) option.

gzip: stdin: unexpected end of file
tar: Child returned status 1
tar: Error is not recoverable: exiting now
Failed to install dependency kit.`

Does this mean I have to compile it on my own machine? By the way, I am using a Raspberry Pi 2 Model B that is SSH’d to my MacBook Air.

Thank you for your recommendations.

This workaround with replacing the most recent version of the SSL libraries (which seem to be buggy) with older but working versions worked for me.