Favicon not showing up on Galaxy

Our favicon is not showing up when hosting the app on Galaxy. There are no issues on our local machine. Any ideas what this could be? Location is /public/favicon.png. Thanks!

If I remember correctly, special handling here uses favicon.ico as the filename

1 Like

Converted the PNG to ICO and moved it in and out of /public.

But the icon didn’t show up. Will wait a bit and see if it’s a caching issue. If this doesn’t work, it might be an option to host the icon on a separate server.

How are you referring to the favicon in your HTML @c6y? It should work on Galaxy without any issues.

We use it in our projects by simply adding it to the public folder and including the appropriate tags in our main.html.

<link rel="shortcut icon" type="image/x-icon" href="/favicon.ico">

To ensure it is not a cache issue, you can add a parameter to your URL that forces the browser to download it. You could append ?v=1 to the favicon URL, resulting in the following format:

<link rel="shortcut icon" type="image/x-icon" href="/favicon.ico?v=1">

Thanks Fred! The issue is solved. The icon never showed because I was including the public directory in the link. href="/public/favicon.ico" :frowning_face:

1 Like