Fibers missing from Meteor bundle, not building with node


#1

Earlier I learned that upgrading to Meteor 1.2 meant downgrading from Node.js 0.12.7 to 0.10.40. After doing this on my Windows deployment server and attempting to start up Meteor using Node, I receive the following error:

> [path hidden]\programs\server\node_modules\fibers\fibers.js:16
> 	throw new Error('`'+ modPath+ '.node` is missing. Try reinstalling `node-fibe
> 	      ^
> Error: `[path hidden]\programs\server\node_modules\fibers\bin\win32-x64-v8-3.14\fibers.node` is missing. Try reinstalling `node-fibers`?
>     at Object.<anonymous> ([path hidden]\programs\server\node_modules\fibers\fibers.js:16:8)
>     at Module._compile (module.js:456:26)
>     at Object.Module._extensions..js (module.js:474:10)
>     at Module.load (module.js:356:32)
>     at Function.Module._load (module.js:312:12)
>     at Module.require (module.js:364:17)
>     at require (module.js:380:17)
>     at Object.<anonymous> ([path hidden]\programs\server\boot.js:1:75)
>     at Module._compile (module.js:456:26)
>     at Object.Module._extensions..js (module.js:474:10)

The bundle includes a fibers.node in a win32-x64-v8-3.14 directory, not the win32-x64-v8-3.28 folder that Node is expecting. I tried doing a cheeky directory name change but then received the following node error:

module.js:356
  Module._extensions[extension](this, filename);

Error: The specified procedure could not be found.
[path]\programs\server\node_modules\fibers\bin\win32-x64-v8-3.14\fibers.node
at Module.load (module.js:356:32)

Please note that the server does not have internet access so I would only be able to copy files from a local machine that has internet access.


#2

Did you find a solution for this. I have this issue in my development environment. Build Just worked yesterday. Today when i tried to start with ‘meteor’ i get the same issue in my Windows machine. The folder is not where it is supposed to be.


#3

cd /home/user/my_meteor_application/programs/server
npm install --production

That’ll do ya.

:")


#4

I suppose if you’re on a windows machine it’s a bit different. I THINK I’ve had this issue, and you’ll have to use the command prompt to do the same thing.

Another option is to create a new meteor project and move your stuff in to it. I’ve had to do that a few times.


#5

Thanks, that did the trick. I had to remove the .meteor folder.