Fix for meteor-up on Node v6

Dunno if anyone else besides me still uses Meteor-up for deployments, but I’ve just updated my meteor-up fork to support Node v6 on host machines. Previously if you hade v6 on your machine and tried to deploy, you would get an error. This is now resolved by updating one of the dependencies which was incompatible with v6.


Thanks, good to know! I saw your fork is based on the “legacy” mup, i.e. the version that does not use Docker. Is there a special reason for that? Is there anything to consider if one switches from dockerized mupx to your mup fork? I don’t care about Docker as such, but it seemed to be the go-forward mup approach until Kadira stopped Meteor development completely.

No special reason, I just didn’t saw a need to move to a Dockerized version when the “legacy” version worked just fine for me. Docker is yet another abstraction and yet another moving part in this process that could break, so I opted with staying with the legacy version and fixing small problems from time to time instead of moving to something entirely new (which also was later abandoned, as we all know now). With classic meteor-up I know exactly how it works and where to look when it doesn’t work :slight_smile:

1 Like

Thanks for the additional insights. Yes, I also try to keep the number of moving parts low.