Fix proxy deny issue

On my phone at home I tried the meteor app and it worked.
I came into work and used the same external access on my phone as I do my macbook and it didn’t work on my phone.

So I looked at my firewall and saw this.

2017-09-28 08:23:18 Deny http/tcp 49709 80 4-PennEngineering 2-FiOS Line ProxyDeny: HTTP Invalid Request-Line format (TCP-UDP-proxy-00) HTTP-Client.Standard.1 proc_id=“http-proxy” rc=“595” msg_id=“1AFF-0005” proxy_act=“HTTP-Client.Standard.1” line="\x88\x80S.\x95\xf1" geo_dst="USA"

The firewall uses a proxy to inspect the traffic for issues, AV etc.
I added a rule to to not use the proxy but just a packet filter and the site comes up.

From what I have found:

The Request-Line is the HTTP command that is sent to the server to either request a page or send some data. It is the GET, POST, HEAD, OPTIONS, etc. part of the command. There is something incorrect in the programming of the website.

How can I fix the Meteor app?
Please help.