.Folder is ignored even in public directory

I am trying to setup SSL via letsencrypt. It requires a folder .well_known

But when i place it in public folder it is getting ignored. Any workarounds for this ?

Tried a symbolic link? It could be that the dot is messing with the enumeration as it usually denotes a directory which should be ignored.

In your public folder:

ln -s ./.well_known not_ignored

Hmm, what you mean by ‘ignored’?
For me it isn’t ignored, maybe your IDE ignores it or your system hides folders with dot ?

I use meteorhacks:picker for letsencrypt on Heroku. I also use Meteor settings to save the letsencrypt ID.

import { Meteor } from 'meteor/meteor';
import { Picker } from 'meteor/meteorhacks:picker';

Picker.route('/.well-known/acme-challenge/:id', (params, req, res) => {
  const { id } = params;
  const { letsencryptId } = Meteor.settings;

1 Like

I am using meteor galaxy to deploy the app. This folder is not getting picked up. I am using mac and the folder is visible.

Thanks for this tip. Ill try this today

1 Like