Force SSL Error.. [MUP]


#1

Hello, I am using mup to deploy my application.

Now, I was trying to update some stuff for my homepage and tried to push it today. 3-5 weeks ago when I last updated my homepage everything just worked fine beside some small bugs I could handle.
But now it doesn’t let me setup or deploy my app with mup anymore.

It tells me:
Error loading config file:
forceSSL: true
^^^^^^^^

SyntaxError: Unexpected identifier…

My config looks like:

module.exports = {
  servers: {
    one: {
      // TODO: set host address, username, and authentication method
      host: 'xxxxxxxxxxxxx',
      username: 'xxxxx',
      // pem: './path/to/pem'
      password: 'xxxxxxxxxx'
      // or neither for authenticate from ssh-agent
    }
  },

  meteor: {
    // TODO: change app name and path
    name: 'Home',
    path: '../../Home',
    servers: {
      one: {},
    },

    buildOptions: {
      serverOnly: true,
    },

    env: {
      // TODO: Change to your app's url
      // If you are using ssl, it needs to start with https://
      ROOT_URL: 'https://www.xxxxxx.eu/',
      MONGO_URL: 'mongodb://localhost/meteor',
    },
 ssl: {
    crt: '../../Home/www.xxxxxxxxx.eu_ssl_certificate.cer', // this is a bundle of certificates
    key: '../../Home/www.xxxxxxxxxx.eu_private_key.key', // this is the private key of the certificate
    port: 443 // 443 is the default value and it's the standard HTTPS port
	forceSSL: true
  },
    docker: {
      // change to 'kadirahq/meteord' if your app is not using Meteor 1.4
      image: 'abernix/meteord:node-8.4.0-base',
      //imagePort: 80, // (default: 80, some images EXPOSE different ports)
    },

    // This is the maximum time in seconds it will wait
    // for your app to start
    // Add 30 seconds if the server has 512mb of ram
    // And 30 more if you have binary npm dependencies.
    deployCheckWaitTime: 520,

    // Show progress bar while uploading bundle to server
    // You might need to disable it on CI servers
    enableUploadProgressBar: true
  
  },

  mongo: {
    port: 27017,
    version: '3.4.1',
    servers: {
      one: {}
    }
  }
};

I tried it with the proxy way but it tells me:
4 Validation Errors:
servers.proxy.host
servers.proxy.username
servers.proxy.domain
servser.proxy.ssl

unknown property

It also tells me to look into the docs… But I couldn’t find anything similar or helpful for my problem.

Would be nice if u can help since I have to update my homapge due to the privacy law…


#2

I can see you have no comma after port: 443.