Fourseven:scss Install problems

I’m having real problems installing fourseven:scss. The subject has come up before in this forum, but I’m wondering if this is something new.

I’m using a Mac with the M1 chip and have been for a couple of years with multiple projects using fourseven:scss with no problems.

That was until I just updated a project to meteor v2.13.3 which basically broke everything.

Since the last time I updated meteor, I have updated my Max OS to Sonoma (14.1). So, I’m not sure if it’s Meteor, Sonoma or me messing with Python installs that has cause the problem. Hence, the new thread on the subject.

I’ve tried all sorts of things - including the solution suggested here: [SOLVED] - Fourseven:scss package problem during installation node-sass on macOS regarding python updates etc. No joy.

This is the first line of the error message, then it goes downhill from there!!

At the end of the day, there isn’t a darwin-arm64-83_binding.node to download, but there is a darwin-x64-83_binding.node

Anyone have any thoughts on troubleshooting?

=> Errors while adding packages:             
While loading package fourseven:scss@4.16.0:
error: Command failed: /Users/robwheatley/.meteor/packages/meteor-tool/.2.13.3.s3zrs7.qh67o++os.osx.arm64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.arm64/dev_bundle/bin/npm rebuild --update-binary
Cannot download "": 

HTTP error 404 Not Found

If you will search this forum, you will find same my post. Somebody put some solution for that, but I was not ok with it, because node-sass library is deprecated, therefore I was created my own scss nodsec:scss, which is using lib-sass.


@klaucode you are an absolute hero!! :grin:

I must admit, I didn’t see that you had created this in my frantic and unorganised search for a solution. I just spent ages messing around with different types if Meteor install and different versions of python.

Your solution works perfectly out of the box.

Many, many thanks!


haha, thanks a lot and have a nice day :smiley: